summaryrefslogtreecommitdiffstats
path: root/sax/Library_sax.mk
diff options
context:
space:
mode:
Diffstat (limited to 'sax/Library_sax.mk')
-rw-r--r--sax/Library_sax.mk42
1 files changed, 42 insertions, 0 deletions
diff --git a/sax/Library_sax.mk b/sax/Library_sax.mk
new file mode 100644
index 000000000..6e84a0426
--- /dev/null
+++ b/sax/Library_sax.mk
@@ -0,0 +1,42 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,sax))
+
+$(eval $(call gb_Library_set_include,sax,\
+ -I$(SRCDIR)/sax/inc \
+ $$(INCLUDE) \
+))
+
+$(eval $(call gb_Library_use_external,sax,boost_headers))
+
+$(eval $(call gb_Library_use_common_precompiled_header,sax))
+
+$(eval $(call gb_Library_use_sdk_api,sax))
+
+$(eval $(call gb_Library_use_libraries,sax,\
+ comphelper \
+ cppu \
+ cppuhelper \
+ sal \
+ tl \
+))
+
+$(eval $(call gb_Library_add_defs,sax,\
+ -DSAX_DLLIMPLEMENTATION \
+))
+
+$(eval $(call gb_Library_add_exception_objects,sax,\
+ sax/source/tools/converter \
+ sax/source/tools/fastattribs \
+ sax/source/tools/fastserializer \
+ sax/source/tools/fshelper \
+))
+
+# vim: set noet sw=4 ts=4: