summaryrefslogtreecommitdiffstats
path: root/sc/CppunitTest_sc_tablesheetobj.mk
diff options
context:
space:
mode:
Diffstat (limited to 'sc/CppunitTest_sc_tablesheetobj.mk')
-rw-r--r--sc/CppunitTest_sc_tablesheetobj.mk49
1 files changed, 49 insertions, 0 deletions
diff --git a/sc/CppunitTest_sc_tablesheetobj.mk b/sc/CppunitTest_sc_tablesheetobj.mk
new file mode 100644
index 000000000..52f7f427b
--- /dev/null
+++ b/sc/CppunitTest_sc_tablesheetobj.mk
@@ -0,0 +1,49 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#*************************************************************************
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+#*************************************************************************
+
+$(eval $(call gb_CppunitTest_CppunitTest,sc_tablesheetobj))
+
+$(eval $(call gb_CppunitTest_use_external,sc_tablesheetobj,boost_headers))
+
+$(eval $(call gb_CppunitTest_use_common_precompiled_header,sc_tablesheetobj))
+
+$(eval $(call gb_CppunitTest_add_exception_objects,sc_tablesheetobj, \
+ sc/qa/extras/sctablesheetobj \
+))
+
+$(eval $(call gb_CppunitTest_use_libraries,sc_tablesheetobj, \
+ cppu \
+ sal \
+ salhelper \
+ sc \
+ subsequenttest \
+ test \
+ unotest \
+))
+
+$(eval $(call gb_CppunitTest_set_include,sc_tablesheetobj,\
+ -I$(SRCDIR)/sc/inc \
+ $$(INCLUDE) \
+))
+
+$(eval $(call gb_CppunitTest_use_sdk_api,sc_tablesheetobj))
+
+$(eval $(call gb_CppunitTest_use_ure,sc_tablesheetobj))
+$(eval $(call gb_CppunitTest_use_vcl,sc_tablesheetobj))
+
+$(eval $(call gb_CppunitTest_use_components,sc_tablesheetobj,\
+ $(sc_unoapi_common_components) \
+ i18npool/source/search/i18nsearch \
+))
+
+$(eval $(call gb_CppunitTest_use_configuration,sc_tablesheetobj))
+
+# vim: set noet sw=4 ts=4: