summaryrefslogtreecommitdiffstats
path: root/scp2/CustomTarget_langmacros.mk
diff options
context:
space:
mode:
Diffstat (limited to 'scp2/CustomTarget_langmacros.mk')
-rw-r--r--scp2/CustomTarget_langmacros.mk23
1 files changed, 23 insertions, 0 deletions
diff --git a/scp2/CustomTarget_langmacros.mk b/scp2/CustomTarget_langmacros.mk
new file mode 100644
index 000000000..48cb59633
--- /dev/null
+++ b/scp2/CustomTarget_langmacros.mk
@@ -0,0 +1,23 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_CustomTarget_CustomTarget,scp2/macros))
+
+$(call gb_CustomTarget_get_target,scp2/macros) : $(call gb_CustomTarget_get_workdir,scp2/macros)/langmacros.inc
+
+$(call gb_CustomTarget_get_workdir,scp2/macros)/langmacros.inc :| $(call gb_CustomTarget_get_workdir,scp2/macros)/.dir
+
+$(call gb_CustomTarget_get_workdir,scp2/macros)/langmacros.inc : $(SRCDIR)/scp2/macros/macro.pl $(BUILDDIR)/config_host.mk.stamp
+ $(call gb_Helper_abbreviate_dirs,\
+ export COMPLETELANGISO_VAR='$(gb_ScpTemplateTarget_LANGS)' && \
+ export HELP_LANGS='$(gb_HELP_LANGS)' && \
+ $(PERL) $< -verbose -o $@ -c $(BUILDDIR)/config_host.mk.stamp \
+ )
+
+# vim: set shiftwidth=4 tabstop=4 noexpandtab: