summaryrefslogtreecommitdiffstats
path: root/scp2/InstallModule_base.mk
diff options
context:
space:
mode:
Diffstat (limited to 'scp2/InstallModule_base.mk')
-rw-r--r--scp2/InstallModule_base.mk39
1 files changed, 39 insertions, 0 deletions
diff --git a/scp2/InstallModule_base.mk b/scp2/InstallModule_base.mk
new file mode 100644
index 000000000..709d1493e
--- /dev/null
+++ b/scp2/InstallModule_base.mk
@@ -0,0 +1,39 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_InstallModule_InstallModule,scp2/base))
+
+$(eval $(call gb_InstallModule_use_auto_install_libs,scp2/base,\
+ base \
+ base_brand \
+ firebirdsdbc \
+ postgresqlsdbc \
+))
+
+$(eval $(call gb_InstallModule_define_if_set,scp2/base,\
+ ENABLE_MACOSX_SANDBOX \
+ ENABLE_FIREBIRD_SDBC \
+ SYSTEM_FIREBIRD \
+))
+
+$(eval $(call gb_InstallModule_add_templates,scp2/base,\
+ scp2/source/templates/module_langpack_base \
+))
+
+$(eval $(call gb_InstallModule_add_scpfiles,scp2/base,\
+ scp2/source/base/file_base \
+ scp2/source/base/firebird \
+))
+
+$(eval $(call gb_InstallModule_add_localized_scpfiles,scp2/base,\
+ scp2/source/base/module_base \
+ scp2/source/base/postgresqlsdbc \
+))
+
+# vim: set shiftwidth=4 tabstop=4 noexpandtab: