summaryrefslogtreecommitdiffstats
path: root/scp2/InstallModule_extensions.mk
diff options
context:
space:
mode:
Diffstat (limited to 'scp2/InstallModule_extensions.mk')
-rw-r--r--scp2/InstallModule_extensions.mk24
1 files changed, 24 insertions, 0 deletions
diff --git a/scp2/InstallModule_extensions.mk b/scp2/InstallModule_extensions.mk
new file mode 100644
index 000000000..fe5a969d6
--- /dev/null
+++ b/scp2/InstallModule_extensions.mk
@@ -0,0 +1,24 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_InstallModule_InstallModule,scp2/extensions))
+
+$(eval $(call gb_InstallModule_use_auto_install_libs,scp2/extensions,extensions_bsh))
+$(eval $(call gb_InstallModule_use_auto_install_libs,scp2/extensions,extensions_rhino))
+$(eval $(call gb_InstallModule_use_auto_install_libs,scp2/extensions,extensions_numbertext))
+
+$(eval $(call gb_InstallModule_add_scpfiles,scp2/extensions,\
+ scp2/source/extensions/file_extensions \
+))
+
+$(eval $(call gb_InstallModule_add_localized_scpfiles,scp2/extensions,\
+ scp2/source/extensions/module_extensions \
+))
+
+# vim: set shiftwidth=4 tabstop=4 noexpandtab: