summaryrefslogtreecommitdiffstats
path: root/scp2/InstallModule_writer.mk
diff options
context:
space:
mode:
Diffstat (limited to 'scp2/InstallModule_writer.mk')
-rw-r--r--scp2/InstallModule_writer.mk33
1 files changed, 33 insertions, 0 deletions
diff --git a/scp2/InstallModule_writer.mk b/scp2/InstallModule_writer.mk
new file mode 100644
index 000000000..cfc4d9a95
--- /dev/null
+++ b/scp2/InstallModule_writer.mk
@@ -0,0 +1,33 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_InstallModule_InstallModule,scp2/writer))
+
+$(eval $(call gb_InstallModule_use_auto_install_libs,scp2/writer,\
+ writer \
+ writer_brand \
+))
+
+$(eval $(call gb_InstallModule_define_if_set,scp2/writer,\
+ ENABLE_MACOSX_SANDBOX \
+))
+
+$(eval $(call gb_InstallModule_add_templates,scp2/writer,\
+ scp2/source/templates/module_langpack_writer \
+))
+
+$(eval $(call gb_InstallModule_add_scpfiles,scp2/writer,\
+ scp2/source/writer/file_writer \
+))
+
+$(eval $(call gb_InstallModule_add_localized_scpfiles,scp2/writer,\
+ scp2/source/writer/module_writer \
+))
+
+# vim: set shiftwidth=4 tabstop=4 noexpandtab: