summaryrefslogtreecommitdiffstats
path: root/sdext/Executable_pdfunzip.mk
diff options
context:
space:
mode:
Diffstat (limited to 'sdext/Executable_pdfunzip.mk')
-rw-r--r--sdext/Executable_pdfunzip.mk42
1 files changed, 42 insertions, 0 deletions
diff --git a/sdext/Executable_pdfunzip.mk b/sdext/Executable_pdfunzip.mk
new file mode 100644
index 000000000..10c179336
--- /dev/null
+++ b/sdext/Executable_pdfunzip.mk
@@ -0,0 +1,42 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Executable_Executable,pdfunzip))
+
+$(eval $(call gb_Executable_use_sdk_api,pdfunzip))
+
+$(eval $(call gb_Executable_use_externals,pdfunzip,\
+ boost_headers \
+ zlib \
+))
+
+$(eval $(call gb_Executable_set_include,pdfunzip,\
+ -I$(SRCDIR)/sdext/source/pdfimport/inc \
+ $$(INCLUDE) \
+))
+
+$(eval $(call gb_Executable_use_libraries,pdfunzip,\
+ basegfx \
+ comphelper \
+ cppu \
+ cppuhelper \
+ sal \
+ vcl \
+ tl \
+ xo \
+ i18nutil \
+))
+
+$(eval $(call gb_Executable_use_library_objects,pdfunzip,pdfimport))
+
+$(eval $(call gb_Executable_add_exception_objects,pdfunzip,\
+ sdext/source/pdfimport/test/pdfunzip \
+))
+
+# vim:set noet sw=4 ts=4: