summaryrefslogtreecommitdiffstats
path: root/setup_native/CustomTarget_scripts.mk
diff options
context:
space:
mode:
Diffstat (limited to 'setup_native/CustomTarget_scripts.mk')
-rw-r--r--setup_native/CustomTarget_scripts.mk38
1 files changed, 38 insertions, 0 deletions
diff --git a/setup_native/CustomTarget_scripts.mk b/setup_native/CustomTarget_scripts.mk
new file mode 100644
index 000000000..c7f8c5b0a
--- /dev/null
+++ b/setup_native/CustomTarget_scripts.mk
@@ -0,0 +1,38 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+scripts_WORKDIR :=$(call gb_CustomTarget_get_workdir,setup_native/scripts)
+
+$(eval $(call gb_CustomTarget_CustomTarget,setup_native/scripts))
+
+ifeq ($(OS),LINUX)
+ifneq ($(filter rpm,$(PKGFORMAT)),)
+$(eval $(call gb_CustomTarget_register_targets,setup_native/scripts,\
+ install \
+ uninstall \
+ noarch/fake-db-1.0-0.noarch.rpm \
+))
+
+$(scripts_WORKDIR)/noarch/fake-db-1.0-0.noarch.rpm: $(SRCDIR)/setup_native/scripts/fake-db.spec
+ mkdir -p $(scripts_WORKDIR)/fake-db-root
+ $(RPM) --define "_builddir $(scripts_WORKDIR)/fake-db-root" \
+ --define "_rpmdir $(scripts_WORKDIR)" -bb $<
+ chmod g+w $(scripts_WORKDIR)/fake-db-root
+
+$(scripts_WORKDIR)/install: $(SRCDIR)/setup_native/scripts/install_linux.sh $(scripts_WORKDIR)/noarch/fake-db-1.0-0.noarch.rpm
+ $(PERL) -w $(SRCDIR)/setup_native/scripts/install_create.pl $^ $@
+ chmod 775 $@
+
+$(scripts_WORKDIR)/uninstall: $(SRCDIR)/setup_native/scripts/uninstall_linux.sh
+ cat $< | tr -d "\015" > $@
+ chmod 775 $@
+endif
+endif
+
+# vim: set noet sw=4 ts=4: