summaryrefslogtreecommitdiffstats
path: root/setup_native/Library_instooofiltmsi.mk
diff options
context:
space:
mode:
Diffstat (limited to 'setup_native/Library_instooofiltmsi.mk')
-rw-r--r--setup_native/Library_instooofiltmsi.mk38
1 files changed, 38 insertions, 0 deletions
diff --git a/setup_native/Library_instooofiltmsi.mk b/setup_native/Library_instooofiltmsi.mk
new file mode 100644
index 000000000..36e2e2a6b
--- /dev/null
+++ b/setup_native/Library_instooofiltmsi.mk
@@ -0,0 +1,38 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,instooofiltmsi))
+
+$(eval $(call gb_Library_add_defs,instooofiltmsi,\
+ -U_DLL \
+))
+
+$(eval $(call gb_Library_add_cxxflags,instooofiltmsi,\
+ $(if $(MSVC_USE_DEBUG_RUNTIME),/MTd,/MT) \
+))
+
+$(eval $(call gb_Library_add_ldflags,instooofiltmsi,\
+ /DEF:$(SRCDIR)/setup_native/source/win32/customactions/indexingfilter/instooofiltmsi.def \
+ /NODEFAULTLIB \
+))
+
+$(eval $(call gb_Library_add_exception_objects,instooofiltmsi,\
+ setup_native/source/win32/customactions/indexingfilter/restartindexingservice \
+))
+
+$(eval $(call gb_Library_use_system_win32_libs,instooofiltmsi,\
+ libcmt \
+ libcpmt \
+ libucrt \
+ libvcruntime \
+ kernel32 \
+ advapi32 \
+))
+
+# vim: set noet sw=4 ts=4: