summaryrefslogtreecommitdiffstats
path: root/setup_native/Library_regactivex.mk
diff options
context:
space:
mode:
Diffstat (limited to 'setup_native/Library_regactivex.mk')
-rw-r--r--setup_native/Library_regactivex.mk38
1 files changed, 38 insertions, 0 deletions
diff --git a/setup_native/Library_regactivex.mk b/setup_native/Library_regactivex.mk
new file mode 100644
index 000000000..7142b8ee0
--- /dev/null
+++ b/setup_native/Library_regactivex.mk
@@ -0,0 +1,38 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,regactivex))
+
+$(eval $(call gb_Library_add_defs,regactivex,\
+ -U_DLL \
+))
+
+$(eval $(call gb_Library_add_cxxflags,regactivex,\
+ $(if $(MSVC_USE_DEBUG_RUNTIME),/MTd,/MT) \
+))
+
+$(eval $(call gb_Library_add_ldflags,regactivex,\
+ /DEF:$(SRCDIR)/setup_native/source/win32/customactions/regactivex/regactivex.def \
+ /NODEFAULTLIB \
+))
+
+$(eval $(call gb_Library_add_exception_objects,regactivex,\
+ setup_native/source/win32/customactions/regactivex/regactivex \
+))
+
+$(eval $(call gb_Library_use_system_win32_libs,regactivex,\
+ libcmt \
+ libcpmt \
+ libucrt \
+ libvcruntime \
+ kernel32 \
+ msi \
+))
+
+# vim: set noet sw=4 ts=4: