summaryrefslogtreecommitdiffstats
path: root/sfx2/CppunitTest_sfx2_misc.mk
diff options
context:
space:
mode:
Diffstat (limited to 'sfx2/CppunitTest_sfx2_misc.mk')
-rw-r--r--sfx2/CppunitTest_sfx2_misc.mk44
1 files changed, 44 insertions, 0 deletions
diff --git a/sfx2/CppunitTest_sfx2_misc.mk b/sfx2/CppunitTest_sfx2_misc.mk
new file mode 100644
index 000000000..c97d97ca4
--- /dev/null
+++ b/sfx2/CppunitTest_sfx2_misc.mk
@@ -0,0 +1,44 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_CppunitTest_CppunitTest,sfx2_misc))
+
+$(eval $(call gb_CppunitTest_add_exception_objects,sfx2_misc, \
+ sfx2/qa/cppunit/test_misc \
+))
+
+$(eval $(call gb_CppunitTest_use_sdk_api,sfx2_misc))
+
+$(eval $(call gb_CppunitTest_use_libraries,sfx2_misc, \
+ comphelper \
+ cppu \
+ cppuhelper \
+ test \
+ unotest \
+ vcl \
+ sal \
+ sfx \
+ utl \
+))
+
+$(eval $(call gb_CppunitTest_use_externals,sfx2_misc,\
+ libxml2 \
+ boost_headers \
+))
+
+$(eval $(call gb_CppunitTest_use_sdk_api,sfx2_misc))
+
+$(eval $(call gb_CppunitTest_use_ure,sfx2_misc))
+$(eval $(call gb_CppunitTest_use_vcl,sfx2_misc))
+
+$(eval $(call gb_CppunitTest_use_rdb,sfx2_misc,services))
+
+$(eval $(call gb_CppunitTest_use_configuration,sfx2_misc))
+
+# vim: set noet sw=4 ts=4: