summaryrefslogtreecommitdiffstats
path: root/shell/CppunitTest_shell_zip.mk
diff options
context:
space:
mode:
Diffstat (limited to 'shell/CppunitTest_shell_zip.mk')
-rw-r--r--shell/CppunitTest_shell_zip.mk39
1 files changed, 39 insertions, 0 deletions
diff --git a/shell/CppunitTest_shell_zip.mk b/shell/CppunitTest_shell_zip.mk
new file mode 100644
index 000000000..bbf22a679
--- /dev/null
+++ b/shell/CppunitTest_shell_zip.mk
@@ -0,0 +1,39 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_CppunitTest_CppunitTest,shell_zip))
+
+$(eval $(call gb_CppunitTest_add_exception_objects,shell_zip, \
+ shell/qa/zip/testzipimpl \
+ shell/qa/zip/ziptest \
+))
+
+
+$(eval $(call gb_CppunitTest_set_include,shell_zip,\
+ -I$(SRCDIR)/shell/inc \
+ $$(INCLUDE) \
+))
+
+$(eval $(call gb_CppunitTest_use_externals,shell_zip,\
+ expat \
+ zlib \
+))
+
+$(eval $(call gb_CppunitTest_use_system_win32_libs,shell_zip, \
+ ole32 \
+ kernel32 \
+ msvcprt \
+))
+
+$(eval $(call gb_CppunitTest_use_static_libraries,shell_zip,\
+ shell_xmlparser \
+ shlxthandler_common \
+))
+
+# vim: set noet sw=4 ts=4: