summaryrefslogtreecommitdiffstats
path: root/shell/StaticLibrary_xmlparser.mk
diff options
context:
space:
mode:
Diffstat (limited to 'shell/StaticLibrary_xmlparser.mk')
-rw-r--r--shell/StaticLibrary_xmlparser.mk25
1 files changed, 25 insertions, 0 deletions
diff --git a/shell/StaticLibrary_xmlparser.mk b/shell/StaticLibrary_xmlparser.mk
new file mode 100644
index 000000000..ee49f076f
--- /dev/null
+++ b/shell/StaticLibrary_xmlparser.mk
@@ -0,0 +1,25 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_StaticLibrary_StaticLibrary,shell_xmlparser))
+
+$(eval $(call gb_StaticLibrary_set_include,shell_xmlparser,\
+ -I$(SRCDIR)/shell/inc \
+ $$(INCLUDE) \
+))
+
+$(eval $(call gb_StaticLibrary_use_externals,shell_xmlparser,\
+ expat \
+))
+
+$(eval $(call gb_StaticLibrary_add_exception_objects,shell_xmlparser,\
+ shell/source/all/xml_parser \
+))
+
+# vim: set shiftwidth=4 tabstop=4 noexpandtab: