summaryrefslogtreecommitdiffstats
path: root/shell/WinResTarget_shlxthdl.mk
diff options
context:
space:
mode:
Diffstat (limited to 'shell/WinResTarget_shlxthdl.mk')
-rw-r--r--shell/WinResTarget_shlxthdl.mk23
1 files changed, 23 insertions, 0 deletions
diff --git a/shell/WinResTarget_shlxthdl.mk b/shell/WinResTarget_shlxthdl.mk
new file mode 100644
index 000000000..65628ad5d
--- /dev/null
+++ b/shell/WinResTarget_shlxthdl.mk
@@ -0,0 +1,23 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_WinResTarget_WinResTarget,shlxthdl))
+
+$(eval $(call gb_WinResTarget_set_include,shlxthdl,\
+ $$(INCLUDE) \
+ -I$(SRCDIR)/shell/inc \
+))
+
+$(eval $(call gb_WinResTarget_use_custom_headers,shlxthdl,\
+ shell/source/win32/shlxthandler/res \
+))
+
+$(eval $(call gb_WinResTarget_set_rcfile,shlxthdl,shell/source/win32/shlxthandler/res/shlxthdl))
+
+# vim: set shiftwidth=4 tabstop=4 noexpandtab: