summaryrefslogtreecommitdiffstats
path: root/slideshow/Module_slideshow.mk
diff options
context:
space:
mode:
Diffstat (limited to 'slideshow/Module_slideshow.mk')
-rw-r--r--slideshow/Module_slideshow.mk27
1 files changed, 27 insertions, 0 deletions
diff --git a/slideshow/Module_slideshow.mk b/slideshow/Module_slideshow.mk
new file mode 100644
index 000000000..9cbaff1eb
--- /dev/null
+++ b/slideshow/Module_slideshow.mk
@@ -0,0 +1,27 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Module_Module,slideshow))
+
+$(eval $(call gb_Module_add_targets,slideshow,\
+ Library_slideshow \
+))
+ifeq ($(ENABLE_OPENGL_TRANSITIONS),TRUE)
+$(eval $(call gb_Module_add_targets,slideshow,\
+ Library_OGLTrans \
+ Package_opengl \
+ ))
+endif
+
+$(eval $(call gb_Module_add_check_targets,slideshow,\
+ CppunitTest_slideshow \
+ CppunitTest_slideshow_engine \
+))
+
+# vim: set noet sw=4 ts=4: