summaryrefslogtreecommitdiffstats
path: root/solenv/qa/python/selftest
diff options
context:
space:
mode:
Diffstat (limited to 'solenv/qa/python/selftest')
-rw-r--r--solenv/qa/python/selftest/Executable_gbuildselftestexe.mk16
-rw-r--r--solenv/qa/python/selftest/Library_gbuildselftest.mk37
-rw-r--r--solenv/qa/python/selftest/Library_gbuildselftestdep.mk15
-rw-r--r--solenv/qa/python/selftest/Makefile21
-rw-r--r--solenv/qa/python/selftest/Module_selftest.mk18
-rw-r--r--solenv/qa/python/selftest/selftestdepobject.cxx0
-rw-r--r--solenv/qa/python/selftest/selftestexeobject.cxx1
-rw-r--r--solenv/qa/python/selftest/selftestobject.cxx0
8 files changed, 108 insertions, 0 deletions
diff --git a/solenv/qa/python/selftest/Executable_gbuildselftestexe.mk b/solenv/qa/python/selftest/Executable_gbuildselftestexe.mk
new file mode 100644
index 000000000..c43a77190
--- /dev/null
+++ b/solenv/qa/python/selftest/Executable_gbuildselftestexe.mk
@@ -0,0 +1,16 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Executable_Executable,gbuildselftestexe))
+
+$(eval $(call gb_Executable_add_exception_objects,gbuildselftestexe,\
+ solenv/qa/python/selftest/selftestexeobject \
+))
+
+# vim: set noet sw=4 ts=4:
diff --git a/solenv/qa/python/selftest/Library_gbuildselftest.mk b/solenv/qa/python/selftest/Library_gbuildselftest.mk
new file mode 100644
index 000000000..bed015c09
--- /dev/null
+++ b/solenv/qa/python/selftest/Library_gbuildselftest.mk
@@ -0,0 +1,37 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,gbuildselftest))
+
+$(eval $(call gb_Library_set_include,gbuildselftest,\
+ -Igbuildtojsontestinclude\
+ $$(INCLUDE) \
+))
+
+$(eval $(call gb_Library_add_defs,gbuildselftest,\
+ -DGBUILDSELFTESTDEF \
+))
+
+$(eval $(call gb_Library_add_cxxflags,gbuildselftest,\
+ -DGBUILDSELFTESTCXXFLAG \
+))
+
+$(eval $(call gb_Library_add_cflags,gbuildselftest,\
+ -DGBUILDSELFTESTCFLAG \
+))
+
+$(eval $(call gb_Library_use_libraries,gbuildselftest,\
+ gbuildselftestdep \
+))
+
+$(eval $(call gb_Library_add_exception_objects,gbuildselftest,\
+ solenv/qa/python/selftest/selftestobject \
+))
+
+# vim: set noet sw=4 ts=4:
diff --git a/solenv/qa/python/selftest/Library_gbuildselftestdep.mk b/solenv/qa/python/selftest/Library_gbuildselftestdep.mk
new file mode 100644
index 000000000..b28450c48
--- /dev/null
+++ b/solenv/qa/python/selftest/Library_gbuildselftestdep.mk
@@ -0,0 +1,15 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,gbuildselftestdep))
+
+$(eval $(call gb_Library_add_exception_objects,gbuildselftestdep,\
+ solenv/qa/python/selftest/selftestdepobject \
+))
+# vim: set noet sw=4 ts=4:
diff --git a/solenv/qa/python/selftest/Makefile b/solenv/qa/python/selftest/Makefile
new file mode 100644
index 000000000..3566a727b
--- /dev/null
+++ b/solenv/qa/python/selftest/Makefile
@@ -0,0 +1,21 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+module_directory:=$(dir $(realpath $(firstword $(MAKEFILE_LIST))))
+
+ifeq (,$(BUILDDIR))
+gb_partial_build__makefile_dir=$(dir $(abspath $(firstword $(MAKEFILE_LIST))))
+BUILDDIR := $(gb_partial_build__makefile_dir)../../../..
+endif
+
+gb_GBUILDSELFTEST=t
+
+include $(module_directory)/../../../gbuild/partial_build.mk
+
+# vim: set noet sw=4 ts=4:
diff --git a/solenv/qa/python/selftest/Module_selftest.mk b/solenv/qa/python/selftest/Module_selftest.mk
new file mode 100644
index 000000000..37c53fdbf
--- /dev/null
+++ b/solenv/qa/python/selftest/Module_selftest.mk
@@ -0,0 +1,18 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Module_Module,gbuildtojsontest))
+
+$(eval $(call gb_Module_add_targets,gbuildtojsontest,\
+ Library_gbuildselftestdep \
+ Library_gbuildselftest \
+ Executable_gbuildselftestexe \
+))
+
+# vim: set shiftwidth=4 tabstop=4 noexpandtab:
diff --git a/solenv/qa/python/selftest/selftestdepobject.cxx b/solenv/qa/python/selftest/selftestdepobject.cxx
new file mode 100644
index 000000000..e69de29bb
--- /dev/null
+++ b/solenv/qa/python/selftest/selftestdepobject.cxx
diff --git a/solenv/qa/python/selftest/selftestexeobject.cxx b/solenv/qa/python/selftest/selftestexeobject.cxx
new file mode 100644
index 000000000..78f2de106
--- /dev/null
+++ b/solenv/qa/python/selftest/selftestexeobject.cxx
@@ -0,0 +1 @@
+int main(void) { return 0; }
diff --git a/solenv/qa/python/selftest/selftestobject.cxx b/solenv/qa/python/selftest/selftestobject.cxx
new file mode 100644
index 000000000..e69de29bb
--- /dev/null
+++ b/solenv/qa/python/selftest/selftestobject.cxx