summaryrefslogtreecommitdiffstats
path: root/sot/CppunitTest_sot_test_sot.mk
diff options
context:
space:
mode:
Diffstat (limited to 'sot/CppunitTest_sot_test_sot.mk')
-rw-r--r--sot/CppunitTest_sot_test_sot.mk41
1 files changed, 41 insertions, 0 deletions
diff --git a/sot/CppunitTest_sot_test_sot.mk b/sot/CppunitTest_sot_test_sot.mk
new file mode 100644
index 000000000..1f550759d
--- /dev/null
+++ b/sot/CppunitTest_sot_test_sot.mk
@@ -0,0 +1,41 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#*************************************************************************
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+#*************************************************************************
+
+$(eval $(call gb_CppunitTest_CppunitTest,sot_test_sot))
+
+$(eval $(call gb_CppunitTest_add_exception_objects,sot_test_sot, \
+ sot/qa/cppunit/test_sot \
+))
+
+$(eval $(call gb_CppunitTest_use_libraries,sot_test_sot, \
+ comphelper \
+ cppu \
+ cppuhelper \
+ sal \
+ sot \
+ tl \
+ unotest \
+))
+
+$(eval $(call gb_CppunitTest_set_include,sot_test_sot,\
+ -I$(SRCDIR)/sot/inc \
+ $$(INCLUDE) \
+))
+
+$(eval $(call gb_CppunitTest_use_sdk_api,sot_test_sot,))
+
+$(eval $(call gb_CppunitTest_use_ure,sot_test_sot))
+
+$(eval $(call gb_CppunitTest_use_components,sot_test_sot,\
+ i18npool/util/i18npool \
+))
+
+# vim: set noet sw=4 ts=4: