summaryrefslogtreecommitdiffstats
path: root/static/CustomTarget_wasm-qt5-mandelbrot_moc.mk
diff options
context:
space:
mode:
Diffstat (limited to 'static/CustomTarget_wasm-qt5-mandelbrot_moc.mk')
-rw-r--r--static/CustomTarget_wasm-qt5-mandelbrot_moc.mk37
1 files changed, 37 insertions, 0 deletions
diff --git a/static/CustomTarget_wasm-qt5-mandelbrot_moc.mk b/static/CustomTarget_wasm-qt5-mandelbrot_moc.mk
new file mode 100644
index 000000000..d3da8235c
--- /dev/null
+++ b/static/CustomTarget_wasm-qt5-mandelbrot_moc.mk
@@ -0,0 +1,37 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_CustomTarget_CustomTarget,static/qt5-mandelbrot))
+
+$(call gb_CustomTarget_get_target,static/qt5-mandelbrot) : \
+ $(call gb_CustomTarget_get_workdir,static/qt5-mandelbrot)/renderthread.moc \
+ $(call gb_CustomTarget_get_workdir,static/qt5-mandelbrot)/mandelbrotwidget.moc \
+
+qt5_mandelbrot_MOCDEFS_H := $(call gb_CustomTarget_get_workdir,static/qt5-mandelbrot)/moc_predefs.h
+qt5_mandelbrot_MOCDEFS_CXX := $(call gb_CustomTarget_get_workdir,static/qt5-mandelbrot)/moc_dummy.cxx
+qt5_mandelbrot_WORKDIR := $(call gb_CustomTarget_get_workdir,static/qt5-mandelbrot)/.dir
+
+$(qt5_mandelbrot_MOCDEFS_CXX): | $(qt5_mandelbrot_WORKDIR)
+ touch $@
+
+$(qt5_mandelbrot_MOCDEFS_H): $(qt5_mandelbrot_MOCDEFS_CXX) | $(qt5_mandelbrot_WORKDIR)
+ $(call gb_Output_announce,$(subst $(WORKDIR)/,,$@),$(true),CXX,1)
+ $(call gb_Trace_StartRange,$(subst $(WORKDIR)/,,$@),CXX)
+ $(CXX) -pipe -O2 -std=gnu++11 -fno-exceptions $(gb_EMSCRIPTEN_CPPFLAGS) -dM -E -o $@ $<
+ $(call gb_Trace_EndRange,$(subst $(WORKDIR)/,,$@),MOC)
+
+$(call gb_CustomTarget_get_workdir,static/qt5-mandelbrot)/%.moc : \
+ $(SRCDIR)/static/source/qt5-mandelbrot/%.h \
+ $(qt5_mandelbrot_MOCDEFS_H) | $(qt5_mandelbrot_WORKDIR)
+ $(call gb_Output_announce,$(subst $(WORKDIR)/,,$@),$(true),MOC,1)
+ $(call gb_Trace_StartRange,$(subst $(WORKDIR)/,,$@),MOC)
+ $(MOC5) --include $(qt5_mandelbrot_MOCDEFS_H) $(gb_EMSCRIPTEN_QTDEFS) $< -o $@
+ $(call gb_Trace_EndRange,$(subst $(WORKDIR)/,,$@),MOC)
+
+# vim: set noet sw=4: