summaryrefslogtreecommitdiffstats
path: root/static/Executable_wasm-qt5-mandelbrot.mk
diff options
context:
space:
mode:
Diffstat (limited to 'static/Executable_wasm-qt5-mandelbrot.mk')
-rw-r--r--static/Executable_wasm-qt5-mandelbrot.mk32
1 files changed, 32 insertions, 0 deletions
diff --git a/static/Executable_wasm-qt5-mandelbrot.mk b/static/Executable_wasm-qt5-mandelbrot.mk
new file mode 100644
index 000000000..e7eac9891
--- /dev/null
+++ b/static/Executable_wasm-qt5-mandelbrot.mk
@@ -0,0 +1,32 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Executable_Executable,wasm-qt5-mandelbrot))
+
+$(eval $(call gb_Executable_use_custom_headers,wasm-qt5-mandelbrot,static/qt5-mandelbrot))
+
+$(eval $(call gb_Executable_use_externals,wasm-qt5-mandelbrot,\
+ graphite \
+ freetype \
+ harfbuzz \
+ libpng \
+ qt5 \
+))
+
+$(eval $(call gb_Executable_add_exception_objects,wasm-qt5-mandelbrot,\
+ static/source/qt5-mandelbrot/main \
+ static/source/qt5-mandelbrot/mandelbrotwidget \
+ static/source/qt5-mandelbrot/renderthread \
+))
+
+$(eval $(call gb_Executable_add_defs,wasm-qt5-mandelbrot,\
+ -DVCL_INTERNALS \
+))
+
+# vim: set noet sw=4 ts=4: