summaryrefslogtreecommitdiffstats
path: root/stoc/Library_proxyfac.mk
diff options
context:
space:
mode:
Diffstat (limited to 'stoc/Library_proxyfac.mk')
-rw-r--r--stoc/Library_proxyfac.mk26
1 files changed, 26 insertions, 0 deletions
diff --git a/stoc/Library_proxyfac.mk b/stoc/Library_proxyfac.mk
new file mode 100644
index 000000000..9cd7be33a
--- /dev/null
+++ b/stoc/Library_proxyfac.mk
@@ -0,0 +1,26 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,proxyfac))
+
+$(eval $(call gb_Library_use_udk_api,proxyfac))
+
+$(eval $(call gb_Library_use_libraries,proxyfac,\
+ cppu \
+ cppuhelper \
+ sal \
+))
+
+$(eval $(call gb_Library_set_componentfile,proxyfac,stoc/source/proxy_factory/proxyfac,ure/services))
+
+$(eval $(call gb_Library_add_exception_objects,proxyfac,\
+ stoc/source/proxy_factory/proxyfac \
+))
+
+# vim:set noet sw=4 ts=4: