summaryrefslogtreecommitdiffstats
path: root/svl/CppunitTest_svl_lngmisc.mk
diff options
context:
space:
mode:
Diffstat (limited to 'svl/CppunitTest_svl_lngmisc.mk')
-rw-r--r--svl/CppunitTest_svl_lngmisc.mk36
1 files changed, 36 insertions, 0 deletions
diff --git a/svl/CppunitTest_svl_lngmisc.mk b/svl/CppunitTest_svl_lngmisc.mk
new file mode 100644
index 000000000..377ce7fb6
--- /dev/null
+++ b/svl/CppunitTest_svl_lngmisc.mk
@@ -0,0 +1,36 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_CppunitTest_CppunitTest,svl_lngmisc))
+
+$(eval $(call gb_CppunitTest_add_exception_objects,svl_lngmisc, \
+ svl/qa/unit/test_lngmisc \
+))
+
+# add a list of all needed libraries here
+$(eval $(call gb_CppunitTest_use_libraries,svl_lngmisc, \
+ cppu \
+ cppuhelper \
+ sal \
+ salhelper \
+ svl \
+))
+
+ifeq ($(OS),WNT)
+$(eval $(call gb_CppunitTest_use_system_win32_libs,svl_lngmisc, \
+ oleaut32 \
+))
+endif
+
+$(eval $(call gb_CppunitTest_set_include,svl_lngmisc,\
+ -I$(SRCDIR)/svl/source/inc \
+ $$(INCLUDE) \
+))
+
+# vim: set noet sw=4 ts=4: