summaryrefslogtreecommitdiffstats
path: root/svl/Module_svl.mk
diff options
context:
space:
mode:
Diffstat (limited to 'svl/Module_svl.mk')
-rw-r--r--svl/Module_svl.mk52
1 files changed, 52 insertions, 0 deletions
diff --git a/svl/Module_svl.mk b/svl/Module_svl.mk
new file mode 100644
index 000000000..45bf74915
--- /dev/null
+++ b/svl/Module_svl.mk
@@ -0,0 +1,52 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+# This file incorporates work covered by the following license notice:
+#
+# Licensed to the Apache Software Foundation (ASF) under one or more
+# contributor license agreements. See the NOTICE file distributed
+# with this work for additional information regarding copyright
+# ownership. The ASF licenses this file to you under the Apache
+# License, Version 2.0 (the "License"); you may not use this file
+# except in compliance with the License. You may obtain a copy of
+# the License at http://www.apache.org/licenses/LICENSE-2.0 .
+#
+
+$(eval $(call gb_Module_Module,svl))
+
+$(eval $(call gb_Module_add_targets,svl,\
+ Library_fsstorage \
+ Library_passwordcontainer \
+ Library_svl \
+))
+
+$(eval $(call gb_Module_add_l10n_targets,svl,\
+ AllLangMoTarget_svl \
+))
+
+$(eval $(call gb_Module_add_check_targets,svl,\
+ CppunitTest_svl_adrparse \
+ CppunitTest_svl_inetcontenttype \
+ CppunitTest_svl_itempool \
+ CppunitTest_svl_items \
+ CppunitTest_svl_lngmisc \
+ CppunitTest_svl_lockfiles \
+ CppunitTest_svl_notify \
+ CppunitTest_svl_qa_cppunit \
+ CppunitTest_svl_urihelper \
+))
+
+$(eval $(call gb_Module_add_subsequentcheck_targets,svl,\
+ JunitTest_svl_complex \
+))
+
+#todo: dde platform dependent
+#todo: package_inc
+#todo: map file
+
+# vim: set noet sw=4 ts=4: