summaryrefslogtreecommitdiffstats
path: root/svx/CppunitTest_svx_gallery_test.mk
diff options
context:
space:
mode:
Diffstat (limited to 'svx/CppunitTest_svx_gallery_test.mk')
-rw-r--r--svx/CppunitTest_svx_gallery_test.mk56
1 files changed, 56 insertions, 0 deletions
diff --git a/svx/CppunitTest_svx_gallery_test.mk b/svx/CppunitTest_svx_gallery_test.mk
new file mode 100644
index 000000000..1415dce92
--- /dev/null
+++ b/svx/CppunitTest_svx_gallery_test.mk
@@ -0,0 +1,56 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#*************************************************************************
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+#*************************************************************************
+
+$(eval $(call gb_CppunitTest_CppunitScreenShot,svx_gallery_test))
+
+$(eval $(call gb_CppunitTest_add_exception_objects,svx_gallery_test, \
+ svx/qa/unit/gallery/test_gallery \
+))
+
+$(eval $(call gb_CppunitTest_set_include,svx_gallery_test,\
+ -I$(SRCDIR)/svx/source/inc \
+ -I$(SRCDIR)/svx/inc \
+ $$(INCLUDE) \
+))
+
+$(eval $(call gb_CppunitTest_use_libraries,svx_gallery_test, \
+ sal \
+ utl \
+ svxcore \
+ comphelper \
+ tl \
+ svl \
+ sfx \
+ unotest \
+ test \
+))
+
+$(eval $(call gb_CppunitTest_use_externals,svx_gallery_test,boost_headers))
+
+$(eval $(call gb_CppunitTest_use_vcl,svx_gallery_test))
+
+$(eval $(call gb_CppunitTest_use_sdk_api,svx_gallery_test))
+
+$(eval $(call gb_CppunitTest_use_configuration,svx_gallery_test))
+
+$(eval $(call gb_CppunitTest_use_rdb,svx_gallery_test,services))
+
+$(eval $(call gb_CppunitTest_use_ure,svx_gallery_test))
+
+
+
+
+
+
+
+
+
+# vim: set noet sw=4 ts=4: