summaryrefslogtreecommitdiffstats
path: root/swext/Configuration_mediawiki.mk
diff options
context:
space:
mode:
Diffstat (limited to 'swext/Configuration_mediawiki.mk')
-rw-r--r--swext/Configuration_mediawiki.mk28
1 files changed, 28 insertions, 0 deletions
diff --git a/swext/Configuration_mediawiki.mk b/swext/Configuration_mediawiki.mk
new file mode 100644
index 000000000..99c83e681
--- /dev/null
+++ b/swext/Configuration_mediawiki.mk
@@ -0,0 +1,28 @@
+#
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+#
+
+$(eval $(call gb_Configuration_Configuration,mediawiki,nodeliver))
+
+$(eval $(call gb_Configuration_add_datas,mediawiki,swext/mediawiki/src/registry/data,\
+ org/openoffice/Office/ProtocolHandler.xcu \
+ org/openoffice/Office/Paths.xcu \
+ org/openoffice/TypeDetection/Filter.xcu \
+ org/openoffice/TypeDetection/Types.xcu \
+))
+
+$(eval $(call gb_Configuration_add_localized_datas,mediawiki,swext/mediawiki/src/registry/data,\
+ org/openoffice/Office/Addons.xcu \
+ org/openoffice/Office/OptionsDialog.xcu \
+ org/openoffice/Office/Custom/WikiExtension.xcu \
+))
+
+$(eval $(call gb_Configuration_add_schemas,mediawiki,swext/mediawiki/src/registry/schema,\
+ org/openoffice/Office/Custom/WikiExtension.xcs \
+))