summaryrefslogtreecommitdiffstats
path: root/sysui/desktop/debian
diff options
context:
space:
mode:
Diffstat (limited to 'sysui/desktop/debian')
-rw-r--r--sysui/desktop/debian/control3
-rw-r--r--sysui/desktop/debian/openoffice.org-debian-menus34
-rwxr-xr-xsysui/desktop/debian/postinst185
-rwxr-xr-xsysui/desktop/debian/postrm24
-rwxr-xr-xsysui/desktop/debian/prerm10
5 files changed, 256 insertions, 0 deletions
diff --git a/sysui/desktop/debian/control b/sysui/desktop/debian/control
new file mode 100644
index 000000000..cfcd7074a
--- /dev/null
+++ b/sysui/desktop/debian/control
@@ -0,0 +1,3 @@
+Description: %productname desktop integration
+Maintainer: LibreOffice
+Architecture: all
diff --git a/sysui/desktop/debian/openoffice.org-debian-menus b/sysui/desktop/debian/openoffice.org-debian-menus
new file mode 100644
index 000000000..8d15ccb24
--- /dev/null
+++ b/sysui/desktop/debian/openoffice.org-debian-menus
@@ -0,0 +1,34 @@
+?package(libreoffice-writer):needs="X11" section="Apps/Editors"\
+ title="%PRODUCTNAME Writer" command="%PREFIX -writer"\
+ hints="Word Processors"\
+ kderemove="y"\
+ icon="/usr/share/icons/hicolor/32x32/apps/%ICONPREFIX-writer.png"\
+ icon16x16="/usr/share/icons/hicolor/16x16/apps/%ICONPREFIX-writer.png"
+
+?package(libreoffice-calc):needs="X11" section="Apps/Math"\
+ title="%PRODUCTNAME Calc" command="%PREFIX -calc"\
+ hints="Spreadsheets"\
+ kderemove="y"\
+ icon="/usr/share/icons/hicolor/32x32/apps/%ICONPREFIX-calc.png"\
+ icon16x16="/usr/share/icons/hicolor/16x16/apps/%ICONPREFIX-calc.png"
+
+?package(libreoffice-draw):needs="X11" section="Apps/Graphics"\
+ title="%PRODUCTNAME Draw" command="%PREFIX -draw"\
+ hints="Drawing"\
+ kderemove="y"\
+ icon="/usr/share/icons/hicolor/32x32/apps/%ICONPREFIX-draw.png"\
+ icon16x16="/usr/share/icons/hicolor/16x16/apps/%ICONPREFIX-draw.png"
+
+?package(libreoffice-impress):needs="X11" section="Apps/Graphics"\
+ title="%PRODUCTNAME Impress" command="%PREFIX -impress"\
+ hints="Presentation"\
+ kderemove="y"\
+ icon="/usr/share/icons/hicolor/32x32/apps/%ICONPREFIX-impress.png"\
+ icon16x16="/usr/share/icons/hicolor/16x16/apps/%ICONPREFIX-impress.png"
+
+?package(libreoffice-base):needs="X11" section="Apps/Databases"\
+ title="%PRODUCTNAME Base" command="%PREFIX -base"\
+ hints="Database"\
+ kderemove="y"\
+ icon="/usr/share/icons/hicolor/32x32/apps/%ICONPREFIX-base.png"\
+ icon16x16="/usr/share/icons/hicolor/16x16/apps/%ICONPREFIX-base.png"
diff --git a/sysui/desktop/debian/postinst b/sysui/desktop/debian/postinst
new file mode 100755
index 000000000..dcb91680c
--- /dev/null
+++ b/sysui/desktop/debian/postinst
@@ -0,0 +1,185 @@
+#!/bin/sh
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+# This file incorporates work covered by the following license notice:
+#
+# Licensed to the Apache Software Foundation (ASF) under one or more
+# contributor license agreements. See the NOTICE file distributed
+# with this work for additional information regarding copyright
+# ownership. The ASF licenses this file to you under the Apache
+# License, Version 2.0 (the "License"); you may not use this file
+# except in compliance with the License. You may obtain a copy of
+# the License at http://www.apache.org/licenses/LICENSE-2.0 .
+#
+
+if [ "$1" = "configure" ] ; then # first install
+ # update shared mime-info database
+ if [ -x /usr/bin/update-mime-database ]; then
+ update-mime-database /usr/share/mime
+ fi
+ # update desktop database
+ if [ -x /usr/bin/update-desktop-database ]; then
+ update-desktop-database -q /usr/share/applications
+ fi
+ # update debian style menus
+ if [ -x /usr/bin/update-menus ]; then
+ update-menus
+ fi
+ # update icon-cache if already present
+ if [ -e /usr/share/icons/hicolor/icon-theme.cache ] ; then
+ # touch it, just in case we cannot find the binary...
+ touch /usr/share/icons/hicolor
+ if (which gtk-update-icon-cache); then
+ gtk-update-icon-cache /usr/share/icons/hicolor
+ fi
+ # ignore errors (e.g. when there is a cache, but no index.theme)
+ true
+ fi
+fi
+
+# update /etc/mime.types
+# backing out existing entries to avoid duplicates
+sed '
+/application\/vnd\.oasis\.opendocument/d
+/application\/vnd\.sun/d
+/application\/vnd\.stardivision/d
+/application\/vnd\.openofficeorg/d
+' /etc/mime.types 2>/dev/null >> /etc/mime.types.tmp$$
+
+# now append our stuff to the temporary file
+cat >> /etc/mime.types.tmp$$ << END
+application/vnd.oasis.opendocument.text odt
+application/vnd.oasis.opendocument.text-flat-xml fodt
+application/vnd.oasis.opendocument.text-template ott
+application/vnd.oasis.opendocument.text-web oth
+application/vnd.oasis.opendocument.text-master odm
+application/vnd.oasis.opendocument.text-master-template otm
+application/vnd.oasis.opendocument.graphics odg
+application/vnd.oasis.opendocument.graphics-flat-xml fodg
+application/vnd.oasis.opendocument.graphics-template otg
+application/vnd.oasis.opendocument.presentation odp
+application/vnd.oasis.opendocument.presentation-flat-xml fodp
+application/vnd.oasis.opendocument.presentation-template otp
+application/vnd.oasis.opendocument.spreadsheet ods
+application/vnd.oasis.opendocument.spreadsheet-flat-xml fods
+application/vnd.oasis.opendocument.spreadsheet-template ots
+application/vnd.oasis.opendocument.chart odc
+application/vnd.oasis.opendocument.formula odf
+application/vnd.oasis.opendocument.image odi
+application/vnd.sun.xml.writer sxw
+application/vnd.sun.xml.writer.template stw
+application/vnd.sun.xml.writer.global sxg
+application/vnd.stardivision.writer sdw vor
+application/vnd.stardivision.writer-global sgl
+application/vnd.sun.xml.calc sxc
+application/vnd.sun.xml.calc.template stc
+application/vnd.stardivision.calc sdc
+application/vnd.stardivision.chart sds
+application/vnd.sun.xml.impress sxi
+application/vnd.sun.xml.impress.template sti
+application/vnd.stardivision.impress sdd sdp
+application/vnd.sun.xml.draw sxd
+application/vnd.sun.xml.draw.template std
+application/vnd.stardivision.draw sda
+application/vnd.sun.xml.math sxm
+application/vnd.stardivision.math smf
+application/vnd.sun.xml.base odb
+application/vnd.openofficeorg.extension oxt
+END
+
+# and replace the original file
+mv -f /etc/mime.types.tmp$$ /etc/mime.types 2>/dev/null
+
+# update /etc/mailcap only at initial install
+if [ "$1" = "configure" ]
+then
+ # backing out existing entries to avoid duplicates
+ sed '
+/^# LibreOffice/d
+/^application\/vnd\.oasis\.opendocument/d
+/^application\/vnd\.openofficeorg/d
+/^application\/vnd\.sun/d
+/^application\/vnd\.stardivision/d
+/^application\/vnd\.ms-word/d
+/^application\/vnd\.ms-excel/d
+/^application\/vnd\.ms-powerpoint/d
+/^application\/x-star/d
+/excel/d
+/ms[-]*word/d
+/powerpoint/d
+' /etc/mailcap 2>/dev/null >> /etc/mailcap.tmp$$
+
+ # now append our stuff to the temporary file
+ cat >> /etc/mailcap.tmp$$ << END
+# LibreOffice
+application/vnd.oasis.opendocument.text; %PREFIX -view %s
+application/vnd.oasis.opendocument.text-flat-xml; %PREFIX -view %s
+application/vnd.oasis.opendocument.text-template; %PREFIX -view %s
+application/vnd.oasis.opendocument.text-web; %PREFIX -view %s
+application/vnd.oasis.opendocument.text-master; %PREFIX -view %s
+application/vnd.oasis.opendocument.text-master-template; %PREFIX -view %s
+application/vnd.sun.xml.writer; %PREFIX -view %s
+application/vnd.sun.xml.writer.template; %PREFIX -view %s
+application/vnd.sun.xml.writer.global; %PREFIX -view %s
+application/vnd.stardivision.writer; %PREFIX -view %s
+application/vnd.stardivision.writer-global; %PREFIX -view %s
+application/x-hwp; %PREFIX -view %s
+application/x-starwriter; %PREFIX -view %s
+application/vnd.oasis.opendocument.formula; %PREFIX -view %s
+application/vnd.sun.xml.math; %PREFIX -view %s
+application/vnd.stardivision.math; %PREFIX -view %s
+application/x-starmath; %PREFIX -view %s
+application/msword; %PREFIX -view %s
+application/vnd.oasis.opendocument.spreadsheet; %PREFIX -view %s
+application/vnd.oasis.opendocument.spreadsheet-flat-xml; %PREFIX -view %s
+application/vnd.oasis.opendocument.spreadsheet-template; %PREFIX -view %s
+application/vnd.sun.xml.calc; %PREFIX -view %s
+application/vnd.sun.xml.calc.template; %PREFIX -view %s
+application/vnd.stardivision.calc; %PREFIX -view %s
+application/x-starcalc; %PREFIX -view %s
+application/vnd.stardivision.chart; %PREFIX -view %s
+application/x-starchart; %PREFIX -view %s
+application/excel; %PREFIX -view %s
+application/msexcel; %PREFIX -view %s
+application/vnd.ms-excel; %PREFIX -view %s
+application/x-msexcel; %PREFIX -view %s
+application/vnd.oasis.opendocument.presentation; %PREFIX -view %s
+application/vnd.oasis.opendocument.presentation-flat-xml; %PREFIX -view %s
+application/vnd.oasis.opendocument.presentation-template; %PREFIX -view %s
+application/vnd.sun.xml.impress; %PREFIX -view %s
+application/vnd.sun.xml.impress.template; %PREFIX -view %s
+application/vnd.stardivision.impress; %PREFIX -view %s
+application/x-starimpress; %PREFIX -view %s
+application/powerpoint; %PREFIX -view %s
+application/mspowerpoint; %PREFIX -view %s
+application/vnd.ms-powerpoint; %PREFIX -view %s
+application/x-mspowerpoint; %PREFIX -view %s
+application/vnd.oasis.opendocument.graphics; %PREFIX -view %s
+application/vnd.oasis.opendocument.graphics-flat-xml; %PREFIX -view %s
+application/vnd.oasis.opendocument.graphics-template; %PREFIX -view %s
+application/vnd.sun.xml.draw; %PREFIX -view %s
+application/vnd.sun.xml.draw.template; %PREFIX -view %s
+application/vnd.stardivision.draw; %PREFIX -view %s
+application/x-stardraw; %PREFIX -view %s
+application/vnd.oasis.opendocument.database; %PREFIX -view %s
+application/vnd.sun.xml.base; %PREFIX -view %s
+application/vnd.writerperfect; %PREFIX -view %s
+application/wordperfect5.1; %PREFIX -view %s
+application/x-wordperfect; %PREFIX -view %s
+application/wordperfect; %PREFIX -view %s
+application/vnd.lotus-wordpro; %PREFIX -view %s
+application/wpwin; %PREFIX -view %s
+application/x-mswrite; %PREFIX -view %s
+application/vnd.openofficeorg.extension; %PREFIX %s
+END
+
+ # and replace the original file
+ mv -f /etc/mailcap.tmp$$ /etc/mailcap
+fi
+
+exit 0
diff --git a/sysui/desktop/debian/postrm b/sysui/desktop/debian/postrm
new file mode 100755
index 000000000..0e6099ea5
--- /dev/null
+++ b/sysui/desktop/debian/postrm
@@ -0,0 +1,24 @@
+#!/bin/sh
+# run always - both when upgrading as well as when erasing the package.
+# Make sure this works when converted to .deb using alien.
+if [ "$1" != "purge" ]; then
+ if [ -x /usr/bin/update-mime-database ]; then
+ update-mime-database /usr/share/mime
+ fi
+ if [ -x /usr/bin/update-desktop-database ]; then
+ update-desktop-database -q /usr/share/applications
+ fi
+ if [ -x /usr/bin/update-menus ]; then
+ update-menus
+ fi
+ if [ -e /usr/share/icons/hicolor/icon-theme.cache ] ; then
+ # touch it, just in case we cannot find the binary...
+ touch /usr/share/icons/hicolor
+ if (which gtk-update-icon-cache); then
+ gtk-update-icon-cache /usr/share/icons/hicolor
+ fi
+ # ignore errors (e.g. when there is a cache, but no index.theme)
+ true
+ fi
+fi
+exit 0
diff --git a/sysui/desktop/debian/prerm b/sysui/desktop/debian/prerm
new file mode 100755
index 000000000..d83e09f84
--- /dev/null
+++ b/sysui/desktop/debian/prerm
@@ -0,0 +1,10 @@
+#!/bin/sh
+
+if [ "$1" = "remove" ]
+then
+ # backing all entries pointing to our binary
+ sed '/%PREFIX/d' /etc/mailcap 2>/dev/null >> /etc/mailcap.tmp$$
+
+ # and replace the original file
+ mv -f /etc/mailcap.tmp$$ /etc/mailcap
+fi \ No newline at end of file