summaryrefslogtreecommitdiffstats
path: root/testtools/source/servicetests/makefile.mk
diff options
context:
space:
mode:
Diffstat (limited to 'testtools/source/servicetests/makefile.mk')
-rw-r--r--testtools/source/servicetests/makefile.mk35
1 files changed, 35 insertions, 0 deletions
diff --git a/testtools/source/servicetests/makefile.mk b/testtools/source/servicetests/makefile.mk
new file mode 100644
index 000000000..fd59d8415
--- /dev/null
+++ b/testtools/source/servicetests/makefile.mk
@@ -0,0 +1,35 @@
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+# This file incorporates work covered by the following license notice:
+#
+# Licensed to the Apache Software Foundation (ASF) under one or more
+# contributor license agreements. See the NOTICE file distributed
+# with this work for additional information regarding copyright
+# ownership. The ASF licenses this file to you under the Apache
+# License, Version 2.0 (the "License"); you may not use this file
+# except in compliance with the License. You may obtain a copy of
+# the License at http://www.apache.org/licenses/LICENSE-2.0 .
+#
+
+PRJ := ..$/..
+PRJNAME := testtools
+TARGET := testtools_servicetests
+
+PACKAGE := servicetests
+JAVATESTFILES := LocalServiceTest.java RemoteServiceTest.java
+JAVAFILES := TestBase.java TestService.java
+IDLTESTFILES := \
+ TestService1.idl \
+ TestService2.idl \
+ XTestService1.idl \
+ XTestService2.idl \
+ XTestService3.idl \
+ XTestService4.idl
+JARFILES := juh.jar jurt.jar ridl.jar
+
+.INCLUDE: javaunittest.mk