summaryrefslogtreecommitdiffstats
path: root/ucb/Library_ucpexpand1.mk
diff options
context:
space:
mode:
Diffstat (limited to 'ucb/Library_ucpexpand1.mk')
-rw-r--r--ucb/Library_ucpexpand1.mk30
1 files changed, 30 insertions, 0 deletions
diff --git a/ucb/Library_ucpexpand1.mk b/ucb/Library_ucpexpand1.mk
new file mode 100644
index 000000000..085782a03
--- /dev/null
+++ b/ucb/Library_ucpexpand1.mk
@@ -0,0 +1,30 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,ucpexpand1))
+
+$(eval $(call gb_Library_set_componentfile,ucpexpand1,ucb/source/ucp/expand/ucpexpand1,services))
+
+$(eval $(call gb_Library_use_sdk_api,ucpexpand1))
+
+$(eval $(call gb_Library_use_libraries,ucpexpand1,\
+ comphelper \
+ cppu \
+ cppuhelper \
+ sal \
+ tl \
+ ucbhelper \
+))
+
+$(eval $(call gb_Library_add_exception_objects,ucpexpand1,\
+ ucb/source/ucp/expand/ucpexpand \
+))
+
+# vim: set noet sw=4 ts=4: