summaryrefslogtreecommitdiffstats
path: root/unoidl/CustomTarget_unoidl-check_test.mk
diff options
context:
space:
mode:
Diffstat (limited to 'unoidl/CustomTarget_unoidl-check_test.mk')
-rw-r--r--unoidl/CustomTarget_unoidl-check_test.mk206
1 files changed, 206 insertions, 0 deletions
diff --git a/unoidl/CustomTarget_unoidl-check_test.mk b/unoidl/CustomTarget_unoidl-check_test.mk
new file mode 100644
index 000000000..52ef4d6c3
--- /dev/null
+++ b/unoidl/CustomTarget_unoidl-check_test.mk
@@ -0,0 +1,206 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+# This file incorporates work covered by the following license notice:
+#
+# Licensed to the Apache Software Foundation (ASF) under one or more
+# contributor license agreements. See the NOTICE file distributed
+# with this work for additional information regarding copyright
+# ownership. The ASF licenses this file to you under the Apache
+# License, Version 2.0 (the "License"); you may not use this file
+# except in compliance with the License. You may obtain a copy of
+# the License at http://www.apache.org/licenses/LICENSE-2.0 .
+#
+
+$(eval $(call gb_CustomTarget_CustomTarget,unoidl/unoidl-check_test))
+
+.PHONY: $(call gb_CustomTarget_get_target,unoidl/unoidl-check_test)
+
+$(call gb_CustomTarget_get_target,unoidl/unoidl-check_test): \
+ $(call gb_Executable_get_runtime_dependencies,unoidl-check) \
+ $(call gb_CustomTarget_get_workdir,unoidl/unoidl-check_test)/other1.rdb \
+ $(call gb_CustomTarget_get_workdir,unoidl/unoidl-check_test)/other2.rdb \
+ $(call gb_CustomTarget_get_workdir,unoidl/unoidl-check_test)/pe.rdb \
+ $(call gb_CustomTarget_get_workdir,unoidl/unoidl-check_test)/psa.rdb \
+ $(call gb_CustomTarget_get_workdir,unoidl/unoidl-check_test)/psb.rdb \
+ $(call gb_CustomTarget_get_workdir,unoidl/unoidl-check_test)/ue.rdb \
+ $(call gb_CustomTarget_get_workdir,unoidl/unoidl-check_test)/usa.rdb \
+ $(call gb_CustomTarget_get_workdir,unoidl/unoidl-check_test)/usb.rdb
+ifneq ($(gb_SUPPRESS_TESTS),)
+ @true
+else
+ $(call gb_Helper_abbreviate_dirs,( \
+ $(call gb_Executable_get_command,unoidl-check) --ignore-unpublished \
+ $(call gb_CustomTarget_get_workdir,unoidl/unoidl-check_test)/psa.rdb \
+ -- $(call gb_CustomTarget_get_workdir,unoidl/unoidl-check_test)/psa.rdb) \
+ > $@.log 2>&1 || (cat $@.log && false))
+ $(call gb_Helper_abbreviate_dirs,( \
+ ! $(call gb_Executable_get_command,unoidl-check) --ignore-unpublished \
+ $(call gb_CustomTarget_get_workdir,unoidl/unoidl-check_test)/psa.rdb \
+ -- $(call gb_CustomTarget_get_workdir,unoidl/unoidl-check_test)/psb.rdb) \
+ > $@.log 2>&1 || (cat $@.log && false))
+ $(call gb_Helper_abbreviate_dirs,( \
+ ! $(call gb_Executable_get_command,unoidl-check) --ignore-unpublished \
+ $(call gb_CustomTarget_get_workdir,unoidl/unoidl-check_test)/psa.rdb \
+ -- $(call gb_CustomTarget_get_workdir,unoidl/unoidl-check_test)/usa.rdb) \
+ > $@.log 2>&1 || (cat $@.log && false))
+ $(call gb_Helper_abbreviate_dirs,( \
+ ! $(call gb_Executable_get_command,unoidl-check) --ignore-unpublished \
+ $(call gb_CustomTarget_get_workdir,unoidl/unoidl-check_test)/psa.rdb \
+ -- $(call gb_CustomTarget_get_workdir,unoidl/unoidl-check_test)/usb.rdb) \
+ > $@.log 2>&1 || (cat $@.log && false))
+ $(call gb_Helper_abbreviate_dirs,( \
+ ! $(call gb_Executable_get_command,unoidl-check) --ignore-unpublished \
+ $(call gb_CustomTarget_get_workdir,unoidl/unoidl-check_test)/psa.rdb \
+ -- $(call gb_CustomTarget_get_workdir,unoidl/unoidl-check_test)/pe.rdb) \
+ > $@.log 2>&1 || (cat $@.log && false))
+ $(call gb_Helper_abbreviate_dirs,( \
+ ! $(call gb_Executable_get_command,unoidl-check) --ignore-unpublished \
+ $(call gb_CustomTarget_get_workdir,unoidl/unoidl-check_test)/psa.rdb \
+ -- $(call gb_CustomTarget_get_workdir,unoidl/unoidl-check_test)/ue.rdb) \
+ > $@.log 2>&1 || (cat $@.log && false))
+ $(call gb_Helper_abbreviate_dirs,( \
+ ! $(call gb_Executable_get_command,unoidl-check) --ignore-unpublished \
+ $(call gb_CustomTarget_get_workdir,unoidl/unoidl-check_test)/psa.rdb \
+ -- $(call gb_CustomTarget_get_workdir,unoidl/unoidl-check_test)/other1.rdb) \
+ > $@.log 2>&1 || (cat $@.log && false))
+ $(call gb_Helper_abbreviate_dirs,( \
+ ! $(call gb_Executable_get_command,unoidl-check) --ignore-unpublished \
+ $(call gb_CustomTarget_get_workdir,unoidl/unoidl-check_test)/psa.rdb \
+ -- $(call gb_CustomTarget_get_workdir,unoidl/unoidl-check_test)/other2.rdb) \
+ > $@.log 2>&1 || (cat $@.log && false))
+ $(call gb_Helper_abbreviate_dirs,( \
+ $(call gb_Executable_get_command,unoidl-check) \
+ $(call gb_CustomTarget_get_workdir,unoidl/unoidl-check_test)/psa.rdb \
+ -- $(call gb_CustomTarget_get_workdir,unoidl/unoidl-check_test)/psa.rdb) \
+ > $@.log 2>&1 || (cat $@.log && false))
+ $(call gb_Helper_abbreviate_dirs,( \
+ ! $(call gb_Executable_get_command,unoidl-check) \
+ $(call gb_CustomTarget_get_workdir,unoidl/unoidl-check_test)/psa.rdb \
+ -- $(call gb_CustomTarget_get_workdir,unoidl/unoidl-check_test)/psb.rdb) \
+ > $@.log 2>&1 || (cat $@.log && false))
+ $(call gb_Helper_abbreviate_dirs,( \
+ ! $(call gb_Executable_get_command,unoidl-check) \
+ $(call gb_CustomTarget_get_workdir,unoidl/unoidl-check_test)/psa.rdb \
+ -- $(call gb_CustomTarget_get_workdir,unoidl/unoidl-check_test)/usa.rdb) \
+ > $@.log 2>&1 || (cat $@.log && false))
+ $(call gb_Helper_abbreviate_dirs,( \
+ ! $(call gb_Executable_get_command,unoidl-check) \
+ $(call gb_CustomTarget_get_workdir,unoidl/unoidl-check_test)/psa.rdb \
+ -- $(call gb_CustomTarget_get_workdir,unoidl/unoidl-check_test)/usb.rdb) \
+ > $@.log 2>&1 || (cat $@.log && false))
+ $(call gb_Helper_abbreviate_dirs,( \
+ ! $(call gb_Executable_get_command,unoidl-check) \
+ $(call gb_CustomTarget_get_workdir,unoidl/unoidl-check_test)/psa.rdb \
+ -- $(call gb_CustomTarget_get_workdir,unoidl/unoidl-check_test)/pe.rdb) \
+ > $@.log 2>&1 || (cat $@.log && false))
+ $(call gb_Helper_abbreviate_dirs,( \
+ ! $(call gb_Executable_get_command,unoidl-check) \
+ $(call gb_CustomTarget_get_workdir,unoidl/unoidl-check_test)/psa.rdb \
+ -- $(call gb_CustomTarget_get_workdir,unoidl/unoidl-check_test)/ue.rdb) \
+ > $@.log 2>&1 || (cat $@.log && false))
+ $(call gb_Helper_abbreviate_dirs,( \
+ ! $(call gb_Executable_get_command,unoidl-check) \
+ $(call gb_CustomTarget_get_workdir,unoidl/unoidl-check_test)/psa.rdb \
+ -- $(call gb_CustomTarget_get_workdir,unoidl/unoidl-check_test)/other1.rdb) \
+ > $@.log 2>&1 || (cat $@.log && false))
+ $(call gb_Helper_abbreviate_dirs,( \
+ ! $(call gb_Executable_get_command,unoidl-check) \
+ $(call gb_CustomTarget_get_workdir,unoidl/unoidl-check_test)/psa.rdb \
+ -- $(call gb_CustomTarget_get_workdir,unoidl/unoidl-check_test)/other2.rdb) \
+ > $@.log 2>&1 || (cat $@.log && false))
+ $(call gb_Helper_abbreviate_dirs,( \
+ $(call gb_Executable_get_command,unoidl-check) --ignore-unpublished \
+ $(call gb_CustomTarget_get_workdir,unoidl/unoidl-check_test)/usa.rdb \
+ -- $(call gb_CustomTarget_get_workdir,unoidl/unoidl-check_test)/psa.rdb) \
+ > $@.log 2>&1 || (cat $@.log && false))
+ $(call gb_Helper_abbreviate_dirs,( \
+ $(call gb_Executable_get_command,unoidl-check) --ignore-unpublished \
+ $(call gb_CustomTarget_get_workdir,unoidl/unoidl-check_test)/usa.rdb \
+ -- $(call gb_CustomTarget_get_workdir,unoidl/unoidl-check_test)/psb.rdb) \
+ > $@.log 2>&1 || (cat $@.log && false))
+ $(call gb_Helper_abbreviate_dirs,( \
+ $(call gb_Executable_get_command,unoidl-check) --ignore-unpublished \
+ $(call gb_CustomTarget_get_workdir,unoidl/unoidl-check_test)/usa.rdb \
+ -- $(call gb_CustomTarget_get_workdir,unoidl/unoidl-check_test)/usa.rdb) \
+ > $@.log 2>&1 || (cat $@.log && false))
+ $(call gb_Helper_abbreviate_dirs,( \
+ $(call gb_Executable_get_command,unoidl-check) --ignore-unpublished \
+ $(call gb_CustomTarget_get_workdir,unoidl/unoidl-check_test)/usa.rdb \
+ -- $(call gb_CustomTarget_get_workdir,unoidl/unoidl-check_test)/usb.rdb) \
+ > $@.log 2>&1 || (cat $@.log && false))
+ $(call gb_Helper_abbreviate_dirs,( \
+ $(call gb_Executable_get_command,unoidl-check) --ignore-unpublished \
+ $(call gb_CustomTarget_get_workdir,unoidl/unoidl-check_test)/usa.rdb \
+ -- $(call gb_CustomTarget_get_workdir,unoidl/unoidl-check_test)/pe.rdb) \
+ > $@.log 2>&1 || (cat $@.log && false))
+ $(call gb_Helper_abbreviate_dirs,( \
+ $(call gb_Executable_get_command,unoidl-check) --ignore-unpublished \
+ $(call gb_CustomTarget_get_workdir,unoidl/unoidl-check_test)/usa.rdb \
+ -- $(call gb_CustomTarget_get_workdir,unoidl/unoidl-check_test)/ue.rdb) \
+ > $@.log 2>&1 || (cat $@.log && false))
+ $(call gb_Helper_abbreviate_dirs,( \
+ $(call gb_Executable_get_command,unoidl-check) --ignore-unpublished \
+ $(call gb_CustomTarget_get_workdir,unoidl/unoidl-check_test)/usa.rdb \
+ -- $(call gb_CustomTarget_get_workdir,unoidl/unoidl-check_test)/other1.rdb) \
+ > $@.log 2>&1 || (cat $@.log && false))
+ $(call gb_Helper_abbreviate_dirs,( \
+ $(call gb_Executable_get_command,unoidl-check) --ignore-unpublished \
+ $(call gb_CustomTarget_get_workdir,unoidl/unoidl-check_test)/usa.rdb \
+ -- $(call gb_CustomTarget_get_workdir,unoidl/unoidl-check_test)/other2.rdb) \
+ > $@.log 2>&1 || (cat $@.log && false))
+ $(call gb_Helper_abbreviate_dirs,( \
+ $(call gb_Executable_get_command,unoidl-check) \
+ $(call gb_CustomTarget_get_workdir,unoidl/unoidl-check_test)/usa.rdb \
+ -- $(call gb_CustomTarget_get_workdir,unoidl/unoidl-check_test)/psa.rdb) \
+ > $@.log 2>&1 || (cat $@.log && false))
+ $(call gb_Helper_abbreviate_dirs,( \
+ ! $(call gb_Executable_get_command,unoidl-check) \
+ $(call gb_CustomTarget_get_workdir,unoidl/unoidl-check_test)/usa.rdb \
+ -- $(call gb_CustomTarget_get_workdir,unoidl/unoidl-check_test)/psb.rdb) \
+ > $@.log 2>&1 || (cat $@.log && false))
+ $(call gb_Helper_abbreviate_dirs,( \
+ $(call gb_Executable_get_command,unoidl-check) \
+ $(call gb_CustomTarget_get_workdir,unoidl/unoidl-check_test)/usa.rdb \
+ -- $(call gb_CustomTarget_get_workdir,unoidl/unoidl-check_test)/usa.rdb) \
+ > $@.log 2>&1 || (cat $@.log && false))
+ $(call gb_Helper_abbreviate_dirs,( \
+ ! $(call gb_Executable_get_command,unoidl-check) \
+ $(call gb_CustomTarget_get_workdir,unoidl/unoidl-check_test)/usa.rdb \
+ -- $(call gb_CustomTarget_get_workdir,unoidl/unoidl-check_test)/usb.rdb) \
+ > $@.log 2>&1 || (cat $@.log && false))
+ $(call gb_Helper_abbreviate_dirs,( \
+ ! $(call gb_Executable_get_command,unoidl-check) \
+ $(call gb_CustomTarget_get_workdir,unoidl/unoidl-check_test)/usa.rdb \
+ -- $(call gb_CustomTarget_get_workdir,unoidl/unoidl-check_test)/pe.rdb) \
+ > $@.log 2>&1 || (cat $@.log && false))
+ $(call gb_Helper_abbreviate_dirs,( \
+ ! $(call gb_Executable_get_command,unoidl-check) \
+ $(call gb_CustomTarget_get_workdir,unoidl/unoidl-check_test)/usa.rdb \
+ -- $(call gb_CustomTarget_get_workdir,unoidl/unoidl-check_test)/ue.rdb) \
+ > $@.log 2>&1 || (cat $@.log && false))
+ $(call gb_Helper_abbreviate_dirs,( \
+ ! $(call gb_Executable_get_command,unoidl-check) \
+ $(call gb_CustomTarget_get_workdir,unoidl/unoidl-check_test)/usa.rdb \
+ -- $(call gb_CustomTarget_get_workdir,unoidl/unoidl-check_test)/other1.rdb) \
+ > $@.log 2>&1 || (cat $@.log && false))
+ $(call gb_Helper_abbreviate_dirs,( \
+ ! $(call gb_Executable_get_command,unoidl-check) \
+ $(call gb_CustomTarget_get_workdir,unoidl/unoidl-check_test)/usa.rdb \
+ -- $(call gb_CustomTarget_get_workdir,unoidl/unoidl-check_test)/other2.rdb) \
+ > $@.log 2>&1 || (cat $@.log && false))
+endif
+
+$(call gb_CustomTarget_get_workdir,unoidl/unoidl-check_test)/%.rdb: \
+ $(SRCDIR)/unoidl/qa/unoidl-check/%.idl \
+ $(call gb_Executable_get_runtime_dependencies,unoidl-write) \
+ | $(call gb_CustomTarget_get_workdir,unoidl/unoidl-check_test)/.dir
+ $(call gb_Helper_abbreviate_dirs,( \
+ $(call gb_Executable_get_command,unoidl-write) $< $@))
+
+# vim: set noet sw=4 ts=4: