summaryrefslogtreecommitdiffstats
path: root/unoidl/Executable_unoidl-write.mk
diff options
context:
space:
mode:
Diffstat (limited to 'unoidl/Executable_unoidl-write.mk')
-rw-r--r--unoidl/Executable_unoidl-write.mk31
1 files changed, 31 insertions, 0 deletions
diff --git a/unoidl/Executable_unoidl-write.mk b/unoidl/Executable_unoidl-write.mk
new file mode 100644
index 000000000..cc15bc34d
--- /dev/null
+++ b/unoidl/Executable_unoidl-write.mk
@@ -0,0 +1,31 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Executable_Executable,unoidl-write))
+
+$(eval $(call gb_Executable_add_exception_objects,unoidl-write, \
+ unoidl/source/unoidl-write \
+))
+
+$(eval $(call gb_Executable_use_libraries,unoidl-write, \
+ unoidl \
+ $(if $(filter TRUE,$(DISABLE_DYNLOADING)),reg) \
+ $(if $(filter TRUE,$(DISABLE_DYNLOADING)),store) \
+ salhelper \
+ sal \
+))
+
+ifeq ($(DISABLE_DYNLOADING),TRUE)
+$(eval $(call gb_Executable_use_externals,unoidl-write,\
+ dtoa \
+ zlib \
+))
+endif
+
+# vim: set noet sw=4 ts=4: