summaryrefslogtreecommitdiffstats
path: root/unotest/Jar_test-tools.mk
diff options
context:
space:
mode:
Diffstat (limited to 'unotest/Jar_test-tools.mk')
-rw-r--r--unotest/Jar_test-tools.mk31
1 files changed, 31 insertions, 0 deletions
diff --git a/unotest/Jar_test-tools.mk b/unotest/Jar_test-tools.mk
new file mode 100644
index 000000000..2f8034813
--- /dev/null
+++ b/unotest/Jar_test-tools.mk
@@ -0,0 +1,31 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Jar_Jar,test-tools))
+
+$(eval $(call gb_Jar_add_manifest_classpath,test-tools,\
+ libreoffice.jar \
+))
+
+$(eval $(call gb_Jar_use_jars,test-tools,\
+ libreoffice \
+))
+
+$(eval $(call gb_Jar_set_packageroot,test-tools,org))
+
+$(eval $(call gb_Jar_add_sourcefiles,test-tools,\
+ unotest/source/java/org/openoffice/test/tools/DocumentType \
+ unotest/source/java/org/openoffice/test/tools/OfficeDocument \
+ unotest/source/java/org/openoffice/test/tools/OfficeDocumentView \
+ unotest/source/java/org/openoffice/test/tools/SpreadsheetDocument \
+ unotest/source/java/org/openoffice/test/tools/SpreadsheetView \
+))
+
+# vim: set noet sw=4 ts=4: