summaryrefslogtreecommitdiffstats
path: root/unotest/Jar_test.mk
diff options
context:
space:
mode:
Diffstat (limited to 'unotest/Jar_test.mk')
-rw-r--r--unotest/Jar_test.mk36
1 files changed, 36 insertions, 0 deletions
diff --git a/unotest/Jar_test.mk b/unotest/Jar_test.mk
new file mode 100644
index 000000000..45063ff1c
--- /dev/null
+++ b/unotest/Jar_test.mk
@@ -0,0 +1,36 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Jar_Jar,test))
+
+$(eval $(call gb_Jar_add_manifest_classpath,test,\
+ $(call gb_Helper_make_url,$(call gb_Jar_get_target,libreoffice)) \
+))
+
+$(eval $(call gb_Jar_use_jars,test,\
+ libreoffice \
+ OOoRunner \
+))
+
+$(eval $(call gb_Jar_use_system_jars,test,\
+ $(OOO_JUNIT_JAR) \
+))
+
+$(eval $(call gb_Jar_set_packageroot,test,org))
+
+$(eval $(call gb_Jar_add_sourcefiles,test,\
+ unotest/source/java/org/openoffice/test/Argument \
+ unotest/source/java/org/openoffice/test/FileHelper \
+ unotest/source/java/org/openoffice/test/OfficeConnection \
+ unotest/source/java/org/openoffice/test/OfficeFileUrl \
+ unotest/source/java/org/openoffice/test/UnoApiTest \
+))
+
+# vim: set noet sw=4 ts=4: