summaryrefslogtreecommitdiffstats
path: root/vcl/Executable_ww6fuzzer.mk
diff options
context:
space:
mode:
Diffstat (limited to 'vcl/Executable_ww6fuzzer.mk')
-rw-r--r--vcl/Executable_ww6fuzzer.mk46
1 files changed, 46 insertions, 0 deletions
diff --git a/vcl/Executable_ww6fuzzer.mk b/vcl/Executable_ww6fuzzer.mk
new file mode 100644
index 000000000..527e63346
--- /dev/null
+++ b/vcl/Executable_ww6fuzzer.mk
@@ -0,0 +1,46 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+include $(SRCDIR)/vcl/commonfuzzer.mk
+
+$(eval $(call gb_Executable_Executable,ww6fuzzer))
+
+$(eval $(call gb_Executable_use_api,ww6fuzzer,\
+ offapi \
+ udkapi \
+))
+
+$(eval $(call gb_Executable_use_externals,ww6fuzzer,\
+ $(fuzzer_externals) \
+))
+
+$(eval $(call gb_Executable_set_include,ww6fuzzer,\
+ $$(INCLUDE) \
+ -I$(SRCDIR)/vcl/inc \
+))
+
+$(eval $(call gb_Executable_use_libraries,ww6fuzzer,\
+ $(fuzzer_writer_libraries) \
+ $(fuzzer_core_libraries) \
+))
+
+$(eval $(call gb_Executable_use_static_libraries,ww6fuzzer,\
+ $(fuzzer_statics) \
+))
+
+$(eval $(call gb_Executable_add_exception_objects,ww6fuzzer,\
+ vcl/workben/ww6fuzzer \
+))
+
+$(eval $(call gb_Executable_add_libs,ww6fuzzer,\
+ $(LIB_FUZZING_ENGINE) \
+))
+
+# vim: set noet sw=4 ts=4: