summaryrefslogtreecommitdiffstats
path: root/xmloff/CppunitTest_xmloff_style.mk
diff options
context:
space:
mode:
Diffstat (limited to 'xmloff/CppunitTest_xmloff_style.mk')
-rw-r--r--xmloff/CppunitTest_xmloff_style.mk46
1 files changed, 46 insertions, 0 deletions
diff --git a/xmloff/CppunitTest_xmloff_style.mk b/xmloff/CppunitTest_xmloff_style.mk
new file mode 100644
index 000000000..8d603833c
--- /dev/null
+++ b/xmloff/CppunitTest_xmloff_style.mk
@@ -0,0 +1,46 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#*************************************************************************
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+#*************************************************************************
+
+$(eval $(call gb_CppunitTest_CppunitTest,xmloff_style))
+
+$(eval $(call gb_CppunitTest_use_externals,xmloff_style,\
+ boost_headers \
+ libxml2 \
+))
+
+$(eval $(call gb_CppunitTest_add_exception_objects,xmloff_style, \
+ xmloff/qa/unit/style \
+))
+
+$(eval $(call gb_CppunitTest_use_libraries,xmloff_style, \
+ comphelper \
+ cppu \
+ embobj \
+ sal \
+ test \
+ unotest \
+ utl \
+))
+
+$(eval $(call gb_CppunitTest_use_sdk_api,xmloff_style))
+
+$(eval $(call gb_CppunitTest_use_ure,xmloff_style))
+$(eval $(call gb_CppunitTest_use_vcl,xmloff_style))
+
+$(eval $(call gb_CppunitTest_use_rdb,xmloff_style,services))
+
+$(eval $(call gb_CppunitTest_use_custom_headers,xmloff_style,\
+ officecfg/registry \
+))
+
+$(eval $(call gb_CppunitTest_use_configuration,xmloff_style))
+
+# vim: set noet sw=4 ts=4: