summaryrefslogtreecommitdiffstats
path: root/xmlsecurity/CppunitTest_qa_certext.mk
diff options
context:
space:
mode:
Diffstat (limited to 'xmlsecurity/CppunitTest_qa_certext.mk')
-rw-r--r--xmlsecurity/CppunitTest_qa_certext.mk27
1 files changed, 27 insertions, 0 deletions
diff --git a/xmlsecurity/CppunitTest_qa_certext.mk b/xmlsecurity/CppunitTest_qa_certext.mk
new file mode 100644
index 000000000..faa5459d3
--- /dev/null
+++ b/xmlsecurity/CppunitTest_qa_certext.mk
@@ -0,0 +1,27 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_CppunitTest_CppunitTest,xmlsecurity_qa_certext))
+
+$(eval $(call gb_CppunitTest_use_sdk_api,xmlsecurity_qa_certext))
+
+$(eval $(call gb_CppunitTest_use_libraries,xmlsecurity_qa_certext,\
+ cppu \
+ neon \
+ sal \
+ svl \
+ test \
+ tl \
+))
+
+$(eval $(call gb_CppunitTest_add_exception_objects,xmlsecurity_qa_certext,\
+ xmlsecurity/qa/certext/SanCertExt \
+))
+
+# vim: set noet sw=4 ts=4: