summaryrefslogtreecommitdiffstats
path: root/arch/sh/drivers/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'arch/sh/drivers/Makefile')
-rw-r--r--arch/sh/drivers/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/arch/sh/drivers/Makefile b/arch/sh/drivers/Makefile
new file mode 100644
index 000000000..56b0acace
--- /dev/null
+++ b/arch/sh/drivers/Makefile
@@ -0,0 +1,11 @@
+# SPDX-License-Identifier: GPL-2.0
+#
+# Makefile for the Linux SuperH-specific device drivers.
+#
+
+obj-y += dma/ platform_early.o
+
+obj-$(CONFIG_PCI) += pci/
+obj-$(CONFIG_SUPERHYWAY) += superhyway/
+obj-$(CONFIG_PUSH_SWITCH) += push-switch.o
+obj-$(CONFIG_HEARTBEAT) += heartbeat.o