summaryrefslogtreecommitdiffstats
path: root/arch/sh/kernel/cpu/sh2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'arch/sh/kernel/cpu/sh2/Makefile')
-rw-r--r--arch/sh/kernel/cpu/sh2/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/arch/sh/kernel/cpu/sh2/Makefile b/arch/sh/kernel/cpu/sh2/Makefile
new file mode 100644
index 000000000..214c3a5b1
--- /dev/null
+++ b/arch/sh/kernel/cpu/sh2/Makefile
@@ -0,0 +1,12 @@
+# SPDX-License-Identifier: GPL-2.0
+#
+# Makefile for the Linux/SuperH SH-2 backends.
+#
+
+obj-y := ex.o probe.o entry.o
+
+obj-$(CONFIG_CPU_SUBTYPE_SH7619) += setup-sh7619.o clock-sh7619.o
+
+# SMP setup
+smp-$(CONFIG_CPU_J2) := smp-j2.o
+obj-$(CONFIG_SMP) += $(smp-y)