summaryrefslogtreecommitdiffstats
path: root/debian/rules.d/scripts/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules.d/scripts/Makefile')
-rw-r--r--debian/rules.d/scripts/Makefile48
1 files changed, 48 insertions, 0 deletions
diff --git a/debian/rules.d/scripts/Makefile b/debian/rules.d/scripts/Makefile
new file mode 100644
index 000000000..bbfe9c0d1
--- /dev/null
+++ b/debian/rules.d/scripts/Makefile
@@ -0,0 +1,48 @@
+PROGS = \
+ bin2c \
+ kallsyms \
+ recordmcount \
+ sign-file \
+ unifdef
+
+DATA = \
+ Kbuild.include \
+ Makefile.* \
+ mkversion \
+ module-common.lds \
+ subarch.include
+
+SCRIPTS = \
+ checkincludes.pl \
+ check-local-export \
+ checkstack.pl \
+ checkversion.pl \
+ depmod.sh \
+ gcc-*.sh \
+ gen_initramfs_list.sh \
+ headers_install.sh \
+ kernel-doc \
+ ld-version.sh \
+ Lindent \
+ makelst \
+ mksysmap \
+ mkuboot.sh \
+ modules-check.sh \
+ namespace.pl \
+ pahole-flags.sh \
+ pahole-version.sh \
+ patch-kernel \
+ recordmcount.pl \
+ setlocalversion \
+ ver_linux
+
+SUBDIRS = \
+ basic \
+ genksyms \
+ kconfig \
+ mod
+
+include $(top_rulesdir)/Makefile.inc
+
+CPPFLAGS += -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64
+sign-file: LDLIBS += -lcrypto