summaryrefslogtreecommitdiffstats
path: root/debian/rules.d/scripts/mod/types.h
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules.d/scripts/mod/types.h')
-rw-r--r--debian/rules.d/scripts/mod/types.h12
1 files changed, 12 insertions, 0 deletions
diff --git a/debian/rules.d/scripts/mod/types.h b/debian/rules.d/scripts/mod/types.h
new file mode 100644
index 000000000..bba382183
--- /dev/null
+++ b/debian/rules.d/scripts/mod/types.h
@@ -0,0 +1,12 @@
+/* Minimal definitions for mod_devicetable.h and devicetable-offsets.c */
+typedef unsigned char __u8;
+typedef unsigned short __u16;
+typedef unsigned int __u32;
+typedef unsigned long long __u64;
+typedef struct {
+ __u8 b[16];
+} guid_t;
+typedef guid_t uuid_le;
+typedef unsigned char uuid_t[16];
+#define UUID_STRING_LEN 36
+#define offsetof(a,b) __builtin_offsetof(a,b)