summaryrefslogtreecommitdiffstats
path: root/debian/rules.d/tools/objtool/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules.d/tools/objtool/Makefile')
-rw-r--r--debian/rules.d/tools/objtool/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/debian/rules.d/tools/objtool/Makefile b/debian/rules.d/tools/objtool/Makefile
new file mode 100644
index 000000000..e2bb8c865
--- /dev/null
+++ b/debian/rules.d/tools/objtool/Makefile
@@ -0,0 +1,11 @@
+include $(top_rulesdir)/Makefile.inc
+
+all:
+# For now, only supported target architecture is x86. Later we'll need to build
+# for multiple targets and add a wrapper, same as for modpost.
+# objtool explicitly sets CC and LD to be native tools; we need to override
+# this on the command line to make cross-builds work.
+ $(MAKE) -C $(top_srcdir)/tools/objtool O=$(CURDIR) HOSTARCH=$(KERNEL_ARCH) ARCH=x86 CC=$(CC) LD=$(CROSS_COMPILE)ld V=1 EXTRA_CFLAGS='$(CFLAGS) $(CPPFLAGS)'
+
+install:
+ install -D -m755 objtool $(DESTDIR)/$(installdir)/objtool