summaryrefslogtreecommitdiffstats
path: root/debian/rules.d/tools/tracing/rtla/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules.d/tools/tracing/rtla/Makefile')
-rw-r--r--debian/rules.d/tools/tracing/rtla/Makefile17
1 files changed, 17 insertions, 0 deletions
diff --git a/debian/rules.d/tools/tracing/rtla/Makefile b/debian/rules.d/tools/tracing/rtla/Makefile
new file mode 100644
index 000000000..9dd1cfd41
--- /dev/null
+++ b/debian/rules.d/tools/tracing/rtla/Makefile
@@ -0,0 +1,17 @@
+include $(top_rulesdir)/Makefile.inc
+
+all:
+# Out-of-tree build is not supported, so copy source to the build dir
+ echo '$(UPSTREAMVERSION)' >VERSION
+ rsync -a $(top_srcdir)/tools/tracing/rtla/ .
+ rsync -a $(top_srcdir)/Documentation/tools/rtla/ Documentation/
+ $(MAKE) EXTRA_CFLAGS='$(CFLAGS) $(CPPFLAGS)' EXTRA_LDFLAGS='$(LDFLAGS)' PKG_CONFIG='$(PKG_CONFIG)'
+
+install:
+ $(MAKE) install
+ifneq (,$(filter nodoc,$(DEB_BUILD_PROFILES)))
+ rm -rf $(DESTDIR)/usr/share/man
+endif
+
+clean:
+ rm -rf *