summaryrefslogtreecommitdiffstats
path: root/drivers/android/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'drivers/android/Makefile')
-rw-r--r--drivers/android/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/drivers/android/Makefile b/drivers/android/Makefile
new file mode 100644
index 000000000..c9d3d0c99
--- /dev/null
+++ b/drivers/android/Makefile
@@ -0,0 +1,6 @@
+# SPDX-License-Identifier: GPL-2.0-only
+ccflags-y += -I$(src) # needed for trace events
+
+obj-$(CONFIG_ANDROID_BINDERFS) += binderfs.o
+obj-$(CONFIG_ANDROID_BINDER_IPC) += binder.o binder_alloc.o
+obj-$(CONFIG_ANDROID_BINDER_IPC_SELFTEST) += binder_alloc_selftest.o