summaryrefslogtreecommitdiffstats
path: root/drivers/net/ethernet/hisilicon/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'drivers/net/ethernet/hisilicon/Makefile')
-rw-r--r--drivers/net/ethernet/hisilicon/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/drivers/net/ethernet/hisilicon/Makefile b/drivers/net/ethernet/hisilicon/Makefile
new file mode 100644
index 000000000..7f76d4120
--- /dev/null
+++ b/drivers/net/ethernet/hisilicon/Makefile
@@ -0,0 +1,11 @@
+# SPDX-License-Identifier: GPL-2.0
+#
+# Makefile for the HISILICON network device drivers.
+#
+
+obj-$(CONFIG_HIX5HD2_GMAC) += hix5hd2_gmac.o
+obj-$(CONFIG_HIP04_ETH) += hip04_eth.o
+obj-$(CONFIG_HNS_MDIO) += hns_mdio.o
+obj-$(CONFIG_HNS) += hns/
+obj-$(CONFIG_HNS3) += hns3/
+obj-$(CONFIG_HISI_FEMAC) += hisi_femac.o