summaryrefslogtreecommitdiffstats
path: root/drivers/net/ethernet/microchip/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'drivers/net/ethernet/microchip/Makefile')
-rw-r--r--drivers/net/ethernet/microchip/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/drivers/net/ethernet/microchip/Makefile b/drivers/net/ethernet/microchip/Makefile
new file mode 100644
index 000000000..9faa41436
--- /dev/null
+++ b/drivers/net/ethernet/microchip/Makefile
@@ -0,0 +1,13 @@
+# SPDX-License-Identifier: GPL-2.0-only
+#
+# Makefile for the Microchip network device drivers.
+#
+
+obj-$(CONFIG_ENC28J60) += enc28j60.o
+obj-$(CONFIG_ENCX24J600) += encx24j600.o encx24j600-regmap.o
+obj-$(CONFIG_LAN743X) += lan743x.o
+
+lan743x-objs := lan743x_main.o lan743x_ethtool.o lan743x_ptp.o
+
+obj-$(CONFIG_LAN966X_SWITCH) += lan966x/
+obj-$(CONFIG_SPARX5_SWITCH) += sparx5/