summaryrefslogtreecommitdiffstats
path: root/drivers/pps/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'drivers/pps/Makefile')
-rw-r--r--drivers/pps/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/drivers/pps/Makefile b/drivers/pps/Makefile
new file mode 100644
index 000000000..ceaf65cc1
--- /dev/null
+++ b/drivers/pps/Makefile
@@ -0,0 +1,11 @@
+# SPDX-License-Identifier: GPL-2.0-only
+#
+# Makefile for the PPS core.
+#
+
+pps_core-y := pps.o kapi.o sysfs.o
+pps_core-$(CONFIG_NTP_PPS) += kc.o
+obj-$(CONFIG_PPS) := pps_core.o
+obj-y += clients/ generators/
+
+ccflags-$(CONFIG_PPS_DEBUG) := -DDEBUG