summaryrefslogtreecommitdiffstats
path: root/drivers/soc/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'drivers/soc/Makefile')
-rw-r--r--drivers/soc/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/drivers/soc/Makefile b/drivers/soc/Makefile
new file mode 100644
index 000000000..69ba6508c
--- /dev/null
+++ b/drivers/soc/Makefile
@@ -0,0 +1,35 @@
+# SPDX-License-Identifier: GPL-2.0
+#
+# Makefile for the Linux Kernel SOC specific device drivers.
+#
+
+obj-$(CONFIG_ARCH_ACTIONS) += actions/
+obj-y += apple/
+obj-y += aspeed/
+obj-$(CONFIG_ARCH_AT91) += atmel/
+obj-y += bcm/
+obj-$(CONFIG_SOC_CANAAN) += canaan/
+obj-$(CONFIG_ARCH_DOVE) += dove/
+obj-$(CONFIG_MACH_DOVE) += dove/
+obj-y += fsl/
+obj-y += fujitsu/
+obj-$(CONFIG_ARCH_GEMINI) += gemini/
+obj-y += imx/
+obj-y += ixp4xx/
+obj-$(CONFIG_SOC_XWAY) += lantiq/
+obj-$(CONFIG_LITEX_SOC_CONTROLLER) += litex/
+obj-y += mediatek/
+obj-y += microchip/
+obj-y += pxa/
+obj-y += amlogic/
+obj-y += qcom/
+obj-y += renesas/
+obj-y += rockchip/
+obj-$(CONFIG_SOC_SAMSUNG) += samsung/
+obj-$(CONFIG_SOC_SIFIVE) += sifive/
+obj-y += sunxi/
+obj-$(CONFIG_ARCH_TEGRA) += tegra/
+obj-y += ti/
+obj-$(CONFIG_ARCH_U8500) += ux500/
+obj-$(CONFIG_PLAT_VERSATILE) += versatile/
+obj-y += xilinx/