summaryrefslogtreecommitdiffstats
path: root/fs/iomap/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'fs/iomap/Makefile')
-rw-r--r--fs/iomap/Makefile17
1 files changed, 17 insertions, 0 deletions
diff --git a/fs/iomap/Makefile b/fs/iomap/Makefile
new file mode 100644
index 000000000..fc070184b
--- /dev/null
+++ b/fs/iomap/Makefile
@@ -0,0 +1,17 @@
+# SPDX-License-Identifier: GPL-2.0-or-later
+#
+# Copyright (c) 2019 Oracle.
+# All Rights Reserved.
+#
+
+ccflags-y += -I $(srctree)/$(src) # needed for trace events
+
+obj-$(CONFIG_FS_IOMAP) += iomap.o
+
+iomap-y += trace.o \
+ iter.o
+iomap-$(CONFIG_BLOCK) += buffered-io.o \
+ direct-io.o \
+ fiemap.o \
+ seek.o
+iomap-$(CONFIG_SWAP) += swapfile.o