summaryrefslogtreecommitdiffstats
path: root/net/ax25/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/ax25/Makefile')
-rw-r--r--net/ax25/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/net/ax25/Makefile b/net/ax25/Makefile
new file mode 100644
index 000000000..2e53affc8
--- /dev/null
+++ b/net/ax25/Makefile
@@ -0,0 +1,12 @@
+# SPDX-License-Identifier: GPL-2.0
+#
+# Makefile for the Linux AX.25 layer.
+#
+
+obj-$(CONFIG_AX25) += ax25.o
+
+ax25-y := ax25_addr.o ax25_dev.o ax25_iface.o ax25_in.o ax25_ip.o ax25_out.o \
+ ax25_route.o ax25_std_in.o ax25_std_subr.o ax25_std_timer.o \
+ ax25_subr.o ax25_timer.o ax25_uid.o af_ax25.o
+ax25-$(CONFIG_AX25_DAMA_SLAVE) += ax25_ds_in.o ax25_ds_subr.o ax25_ds_timer.o
+ax25-$(CONFIG_SYSCTL) += sysctl_net_ax25.o