summaryrefslogtreecommitdiffstats
path: root/net/can/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/can/Makefile')
-rw-r--r--net/can/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/net/can/Makefile b/net/can/Makefile
new file mode 100644
index 000000000..58f2c31c1
--- /dev/null
+++ b/net/can/Makefile
@@ -0,0 +1,22 @@
+# SPDX-License-Identifier: GPL-2.0
+#
+# Makefile for the Linux Controller Area Network core.
+#
+
+obj-$(CONFIG_CAN) += can.o
+can-y := af_can.o
+can-$(CONFIG_PROC_FS) += proc.o
+
+obj-$(CONFIG_CAN_RAW) += can-raw.o
+can-raw-y := raw.o
+
+obj-$(CONFIG_CAN_BCM) += can-bcm.o
+can-bcm-y := bcm.o
+
+obj-$(CONFIG_CAN_GW) += can-gw.o
+can-gw-y := gw.o
+
+obj-$(CONFIG_CAN_J1939) += j1939/
+
+obj-$(CONFIG_CAN_ISOTP) += can-isotp.o
+can-isotp-y := isotp.o