summaryrefslogtreecommitdiffstats
path: root/net/ethtool/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/ethtool/Makefile')
-rw-r--r--net/ethtool/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/net/ethtool/Makefile b/net/ethtool/Makefile
new file mode 100644
index 000000000..72ab09442
--- /dev/null
+++ b/net/ethtool/Makefile
@@ -0,0 +1,11 @@
+# SPDX-License-Identifier: GPL-2.0-only
+
+obj-y += ioctl.o common.o
+
+obj-$(CONFIG_ETHTOOL_NETLINK) += ethtool_nl.o
+
+ethtool_nl-y := netlink.o bitset.o strset.o linkinfo.o linkmodes.o \
+ linkstate.o debug.o wol.o features.o privflags.o rings.o \
+ channels.o coalesce.o pause.o eee.o tsinfo.o cabletest.o \
+ tunnels.o fec.o eeprom.o stats.o phc_vclocks.o module.o \
+ pse-pd.o