summaryrefslogtreecommitdiffstats
path: root/net/ieee802154/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/ieee802154/Makefile')
-rw-r--r--net/ieee802154/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/net/ieee802154/Makefile b/net/ieee802154/Makefile
new file mode 100644
index 000000000..f05b7bdae
--- /dev/null
+++ b/net/ieee802154/Makefile
@@ -0,0 +1,10 @@
+# SPDX-License-Identifier: GPL-2.0
+obj-$(CONFIG_IEEE802154) += ieee802154.o
+obj-$(CONFIG_IEEE802154_SOCKET) += ieee802154_socket.o
+obj-y += 6lowpan/
+
+ieee802154-y := netlink.o nl-mac.o nl-phy.o nl_policy.o core.o \
+ header_ops.o sysfs.o nl802154.o trace.o
+ieee802154_socket-y := socket.o
+
+CFLAGS_trace.o := -I$(src)